No joy with encrypting external drives for TM backups

Hello all,

Upgraded to Mojave on my mid-2012 Mac Mini. Figured I would see how it goes there, before pulling my HS MBP (which is my main computer) up to the latest macOS…

Have a external DAS RAID/5 with a backup partition that I was backing up to, as a TM location.
All worked well - but then decided to encrypt the partition. It took days, but I was then met with the “red” exclamation mark, and no further TM backups have occurred.

TM description message reads that the drive IS “encrypted”, but clicking on the red “i”, sees a error/info that reads "Time Machine did not back up because FileVault was encrypting or decrypting a disk. Backups will resume once FileVault finishes."

Did I mention that has been the situation since 27 January?

So, in figuring something went wrong with that particular backup, and since I in any event wanted a off-site backup as well, I tried exactly the same with a new Lacie 2TB Rugged external. This too took the better part of almost 2 weeks (!!??) to finish encrypting – and today, I am met with exactly the same message as the above.

So I now have an external DAS and an external Lacie, both encrypted, but both incapable of actually running TM on them…

Any suggestions? Scrap the encrypted plans, reformat and start again with standard TM backups?

On that note, anyone with Terminal knowledge who thinks this will still work?

sudo diskutil cs list >> to find the Logical Volume Group’s UUID



For the new external, I would format it as an encrypted drive, then do the TM backup.
It sounds like there hasn’t been any sensitive unencrypted data on the drive, so there is no need to encrypt the drive (I.e. encrypt what’s already there). By formatting it as an encrypted drive, all new data will be encrypted on the fly before being written to the disk.


That didn’t occur to me. I certainly tried to encrypt from within TM – but you are correct in the sense that I’m ‘merely’ making backups of photos etc., so nothing too sensitive – it’s just for peace of mind.

So I erase the drive through Disk Utility, by selecting “APFS (Encrypted)” – let that do it’s thing, and then simply TM as normal, without encryption selected?


Back to square 1. @JohnAtl’s kind suggestion did not work. Disk Utility erased and encrypted the Lacie. Removed the drive from TM’s preferences’ pane, and then re-added the (now APFS encrypted drive) back at the TM preference pane… and… no luck!

Same errors as above. Sigh. :roll_eyes:

Hm. I thought TM had to back up to HFS+ partitions…?

Yes, this is true.

Time Machine supports APFS as a source and not a destination. You can’t backup to an APFS destination disk and Time Machine will inform you that the disk needs to be HFS+ if you attempt to do this.


1 Like

Ah - thanks. Will give it another go, this time without APFS.

Edit: No joy.
A notification popped up telling me that my Backup Not Encrypted >> Time Machine is backing up an encrypted disk to an unencrypted disk – which I presume was the point where it was supposed to offer me a way of setting things to allow that…

But then the process just stopped, and I was again met with the same error message with the red “i”…

I have come across similar comments from High Sierra users elsewhere on the web.

It appears that whereas my home drive has finished being encrypted when I turned FileVault on, Time Machine somehow didn’t get the message – and is therefore still in the state where it is waiting for the former process to complete, when it already has…

Looks like I am going to have to call Apple Support. I hope this doesn’t involve a nuke and pave.

**follows topic as something I’m interested in**
Starting to encrypt my backups was something I’ve thought I should perhaps start doing though not made the jump yet.

That said, I’ve been a bit on the fence about it, I saw this video from Rene Ritchie a while back which raised some interesting questions about if you should encrypt backups or not:

I thought perhaps it was worth flagging, I don’t know what data you’re backing up, it might be highly sensitive and you’re absolutely doing the right thing by encrypting. On the other hand, if it’s this much hassle to get it encrypted how certain are you of being able to recover it should you be in a position that needs it (say post hardware failure or something)?

That reminds me, I need to go plug in my Ext USB disk for a TM backup…

1 Like

Maybe doing an encrypted TM backup on an encrypted drive is redundant, and perhaps the source of the problem.
It would seem either an unencrypted backup on an encrypted drive, or an encrypted backup on an unencrypted drive would work and be secure.

1 Like

Apologies, re-read the thread, it was stated previously that it’s not ‘highly sensitive’ data…

@JohnAtl, agreed, going with the notion that it’s not military secrets or plans for the new DeathStar etc; then I would have thought that one layer of encryption should be enough. :grinning:
Another consideration would be performance, doing one layer of encryption can increase the workload & slow down the performance of your system, doing two layers is going to compound that.

Just to confirm, it’s definitely not plans for the new DeathStar, right? :grin:

1 Like

No Death-Star plans… But then again, that’s precisely what someone who was backing up Death-Star plans would say! :sunglasses:

I’ve done some snooping – and it seems all of the above stems from a deeper-level problem, seemingly unrelated to TM backups.

Seems that the greyed-out “Turn off FileVault” under my Security Preferences, points to something having not finished as it should when I tried to encrypt/FileVault my drive.

This despite Terminal’s fdesetup status confirming all as OK – it’s obviously not.
Will report back when I have made sense of where things are at. Regardless, thanks for the suggestions.


Your secret’s safe with me! :face_with_hand_over_mouth:

Hope you get it working ok. :slightly_smiling_face:

I was currently doing this exact same thing with a new 8TB drive. Was going to use it to back up several Mac laptops at home. I have fond no solution to making an encrypted time-machine backup to an APFS Encrypted drive. Please let me know if you discover a solution.

I haven’t looked at the problem since the above. My temporary ‘solution’ was to get Backblaze up and running, so that a backup copy at least exists somewhere:roll_eyes:

I suspect this will involve my having to spend a few days on the phone with Apple - so waiting to have some time off at home, before getting it sorted properly.

Brad it’s been almost a year. I found this thread while trying to see if anyone had recommendations for my problem where all three of my time machine backups stopped working. Did you ever get this resolved? I have made an appointment with Apple, but the first appointment they had was next week.

I did get it sorted, but it involved the old nuke and pave.

Had several calls with Apple, who were very polite, and had me trying quite a few things, but no joy. Eventually had to wipe everything, and restart - external was reformatted, and MacOS was reinstalled. That did the trick, and had it running now as encrypted, ever since.

We still don’t know what the real issue/cause was.

Darn, that must have been frustrating! The whole point of TM is to have a backup for when you need to do just this!