One last effort before I fire Centurylink and risk ending up with worse

To connect directly, you would need to create a new network service (using System Preferences / Network) of type “PPoE”.

Thanks for the quick response. I found this article that steps you through the process:

I’m still not able to connect directly to the ONT via PPPoE after setting up the network service with my ISP’s assigned username and password. (same ones my router uses). There’s a field for PPPoE Service Name, but Centurylink support says there’s nothing required. Do I need to change any defaults behind the service’s “Advanced” button? (TCP/IP, DNS, WINS, Proxies or PPP)


Are you restarting the computer immediately before connecting to the ONT? I would also turn off WiFi before that restart. You want the Mac to grab the ONT as it searches for a network, and a restart with no network connections is a simple way to do that.

Thanks for the quick response. I unplugged the Ethernet cable to the ONT, turned off wireless, restarted the Mac, logged in, plugged in the cable, went to Network preferences and clicked “Connect” for the PPPoE service I’d set up, using the username and password Centurylink gave me.

Still couldn’t connect. Says no PPPoE servers found. Interesting: while trying to connect, my “Ethernet” service moved to the top of the Network preferences window, with “self-assigned IP” on it. I think my IP is normally assigned by the ISP each time restart the Mac.

Here’s another idea…

To check all our Ethernet cabling, I bought a cheap cable tester and everything looked good, except for the two lines going from our router to a double outlet in our living room. They tested with the pattern 36145278, instead of the 12345678 pattern all the others gave. Doesn’t that indicate these are wired as a crossover cable, instead of straight-through?

Everything we’ve connected to these two lines has worked (Apple TV, DirecTV, Playstation…)

But I’m wondering if those differently wired cables on the system could be the source of the intermittent connectivity drops?

I’m starting to reach for long shots!

When I return from some traveling, I may rent a Century Link modem/router for a month or two. Then it really would be “their” problem!

Only a one cent thought here…we don’t have PPOE on our CenturyLink fiber connection. There were a couple of Ethernet ports on the ONT. If we plugged into the same one that went inside it worked, we were fine. If we plugged into the open one, there was no connection for the longest time. Just a thought, that probably doesn’t help, but thought I would throw it out there.

I’m not sure what you mean by the numbers, but strand ordering is a pass or a fail.

Two thoughts occur:

  1. if power cabling passes across or alongside unshielded Ethernet cables. Power to close to copper data cabling can cause interference.
  2. the cabling is broken which causes issues, this doesn’t tend to happen with fixed cabling as it’s in place and protected, but can happen if it’s disturbed.

The tester I bought just sends a signal through the individual wires from position 1 to 8, and its receiver, plugged into the other end of the cable, has LEDs that flash as a result. The transmitter sends in the 12345678 order, and the receiver flashes 12345678 if it’s a “normal” straight-through Ethernet cable. For the line going to my living room, the receiver flashes 36145278, indicating some of the wires are crossed. This particular pattern is consistent with “crossover” Ethernet cables.

I found this information at Ethernet Cable Color Coding Diagram - The Internet Centre

Thanks for the ideas on the cabling. I bought our house new, and it was wired by a Denver company that specializes in data wiring for homes and businesses, so I hope they didn’t make the mistakes you’ve mentioned!


1 Like

A few years back I had connectivity issues that turned out to be buffer bloat, an issue I had never heard of until that time. It was fixed by changing an obscure (to me) network setting, but I think the root cause was having a router that was designed for slower than the then-current internet speeds.

The descriptive version of the problem is that internet traffic goes through a buffer which when incorrectly sized can simply blow up like a balloon rather than letting traffic pass through.

You can read about the issue here and there’s a link to the test page: What Can I Do About Bufferbloat? -

Thanks, Diane. This article says the possible issue is “letting bulk traffic (uploads/downloads) interfere with (and delay) your time-sensitive traffic.”

There’s just two of us in the house, and Apple TV streaming is probably the larges “bulk traffic” item. But supposedly you can stream with around 4Mbps, and we usually get 35-40, so when we’re watching together we’re losing connection with 30+ Mbps unused… Were there others in your case doing a lot of bulk traffic?

But I’ll check it out, just to be sure.