'Open with' causes the beach ball

Wonder if anyone can help, whenever I hover on or even go past ‘open with’ with the cursor in finder or forklift i get the beach ball.
Don’t get it at any other time so am wondering if the my file association db (assuming there is one) is corrupt. Anyone know how to clean it up?
Nothing in google I have seen has a suggestion for cleaning / resetting all. Happens on all file types and not just specific ones.
OS is Catalina.

TIA :slight_smile:

I was having this and deleting my Finder preferences then rebooting cleared it up.


Thanks @ismh that worked great :slight_smile:

I have 1600+ epub files and periodically - maybe once every six weeks - macOS Mojave gets confused when I click ‘Open With.’ I don’t remember if I actually get a beachball but the pop-up window of associated apps starts empty, so I leave it as is, I get up and make a cup of coffee, and usually before it’s in the cup the system has done some sort of necessary reindexing.

Stephen’s solution is far and away the simplest, but it will also delete other Finder settings you may want to hold onto. If you Google “finder open with fetching lsregister,” you’ll find a bunch of people telling you to use the lsregister command in Terminal to rebuild your Launch Services database. The command is super long, mainly because lsregister is buried deep within the bowels of /System/Library/Frameworks. Here’s the command, which should be entered as a single line:

/System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -seed -r -f -domain local -domain user -domain system

(I’m running Mojave, but I doubt the location of lsregister has changed. I first did this seven years ago to solve a different but related Open With problem.)

It can take a long time to run—over 3 minutes on my Late 2012 iMac—but it’s worth it to get Open With acting quickly again.

If you add this line,

alias fixopenwith='/System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -seed -r -f -domain local -domain user -domain system'

to your ~/.bashrc or ~/.bash_profile, you’ll have a fixopenwith command available directly whenever you develop Open With problems—no need to remember that long path or the many command switches.


Thanks! I’m using ZSH and adding it to .zshrc works fine too :smiley: