Option Key Behaving Badly

I use the option key all the time to jump from one word to another or to delete a whole word as I’m typing and it’s stopped working, pretty much, for this specific use. It still works for keyboard shortcuts just not for jumping over words as I type.

I’m not sure if it has to do with the Monterey update?

Interestingly, I can use it as expected in Chrome, but it doesn’t work in Alfred or Mail or Safari. Is anyone else experiencing this? Either way, any ideas for how to troubleshoot?

Also, I can’t type em or en dashes anywhere! Halp!

No problem on my end. Monterey 12.1 Beta, trying it in Safari, Mail, Notes and Pages. Works as intended

First up for troubleshooting is trying a different keyboard. This doesn’t sound like a hardware issue, but it’s an obvious thing to rule out.

1 Like

Have you tried the right-side Option key? Could help rule out hardware vs software issue


It’s working fine for me on both internal and external keyboards.

Some things to try to narrow down the cause (these may be obvious, sorry…)

  • have you accidentally changed the keyboard layout, which may affect option shortcuts?

  • is this occurring with both the right and left option key?

  • go to System Preferences > Keyboard > Keyboard > Modifier Keys and swap the option and command keys around. Do the functions still not work in the new position? Do the cmd functions all work now they’re on the old option key?

I’m thinking that a problem which occurs on that physical key only (a hardware problem) may be different from one which stays with the option key (possibly software).

1 Like

These are great (ahem) options, thank you!

  • The right and left option keys behave the same. Good idea.
  • I’m having the same issue on my external keyboard (Apple Magic keyboard).
  • I fiddled with the modifier mappings and the problem still occurs.

I did plug in and play with a borrowed Moonlander last night. Could that’ve done something?

p.s. I have restarted, but I haven’t done any safe mode/restore stuff.

Are you running Keyboard Maestro, Karabiner, or anything similar?

I am running all the things, Chris.


Update: I’ve reset the PRAM/NVRAM and also booted in SafeMode and the problem still occurs.

Turn all of the things off, one at a time, and see if that fixes it.

I got a notice of a Karabiner update this morning. It’s now at version 14.2.0. Have you updated recently? Nothing in the release notes suggests it’s related, but…

When I do this, I make sure the app is not set to start at login, then I quit the app, then reboot. Maybe I just added unnecessary steps but that’s what I do.

Would booting in Safe Mode achieve the same thing?

I went through and closed out everything I could in the Activity Monitor and (1) I could barely function! and (2) the option key is still misbehaving.

I’ll go remove the start at login items, @neonate.

@margaretamartin I’ll double-check that I’m up-to-date.

I’m running 14.2.0. Oddly, the option key works as expected to navigate text typed in input boxes in Chrome (but not Safari). I can use it as I type this message, but I can’t type an en or emdash. And I can’t navigate text with it in address bar in Chrome.

That is definitely odd.

Maybe something here will help: System Preferences > Accessibility > Keyboard > Navigation

I removed all login items and it still isn’t working properly, however I turned on “guest account” and logged in that way and it worked as expected. So, it seems like it’s a user preference or app thing on my main account.


Okay, it’s fixed!

I’m not sure what happened but I went into System Preferences > Keyboard > Input Sources and added ABC, removed US and Hex, tested, it worked, and re-added UW and Hex and removed ABC and it still works.

Now, with my option key working, I can work!

Thanks for going on this journey with me @margaretamartin @neonate @ChrisUpchurch @brookter @dixonge and @Nick_Fulgham! It helped to have your suggestions and mutual puzzlements.

ETA screenshot I forgot to add


That’s wild! Glad it’s working again, and thanks for sharing the solution that worked. I’ll be filing that one away.