Pdf display in browser

Recently upon opening PDFs they are displayed in browser. Are other people experiencing this?

Welcome back. Sounds like something/someone changed the default app for PDFs from Preview to Safari. No problem.

Just right click on any PDF file, Select Get Info, then change Open With: to Preview, Books, or whatever program you choose. Then Click on “Change All”

PDFs are still set to open in Preview. However today some didn’t. In some ways I actually prefer the new look. The top line looks like this:

BTW my browser today is Firefox.

In Firefox settings, there is an option to tell it to open PDFs in Firefox.

Henceforth you’ll be known as the problem solver. Now I just have to decide which way I like it.

1 Like