Private relay not available on Mac Studio

I just moved from a 27 inch Intel iMac to a Mac Studio. I used migration assistant to move my data and settings and am gradually reinstalling apps. Despite the absence of any new apps aside from moving to the latest version of Parallels (17 to 18) Private Relay is “unavailable - incompatible system settings” on my new machine but works just fine on my old iMac on the same network. The problem persists if Parallels is not running. No VPNs are running. Any suggestions?

I found that Private Relay doesn’t work if I set my Pi-hole as my DNS server.
So I use and

System Preferences
Select the connection, click Advanced…

Thanks for the suggestion, John. I changed my DNS settings but no joy. I’m no using Pi hole. Again the curious thing is the network settings (including DNS) are identical to my intel iMac.

1 Like

Just an update on how I solved this, in case anyone else has a similar issue. I eventually had to downgrade my VPN from the Universal version to the Intel version.

Fist I restarted in safe mode. Private relay worked. I still couldn’t figure out the issue so I restarted and removed all the login apps from the LaunchDaemons and LaunchAgents folders, then added back apps one by one.

The culprit turned out to be Fortinet VPN Client which I need for work. Turning it off didn’t help. Uninstalling and then rebooting fixed it. I reinstalled an older version ( that I had archived but the issue recurred. The same version works fine on my Intel iMac. Only when I downgraded to, Intel only, was I able to get Private Relay working with Fortinet installed.

1 Like