Question regarding item counts in DTTG

Hi tribe, sorry if this has been discussed before, but I haven’t found any related information to my question. I’m using DTTG in its latest version 3.1 on both iPhone and iPad (all with latest iOS versions).

One of my databases is indexed and the sync is no issue; however I just realized that the item count numbers are different on all machines. For example in on the start screen it shows 52 entries (see picture):

On my iPad that same number shows 116 entries??

When I open the database on either device it shows the correct number of 910 entries (see picture):

DEVONthink on the Mac show 910 entries as well.

Sync seems fine to, I found every document that I tried to search for, I tried the long press on the database with sync &repair, I searched around and made sure I have no unread items and lastly I even tried the “fix” Utility URL commands in the appendix of the help section. Nothing seems to make a difference.

Has anybody an idea what causes this behavior and how to fix? I’m pretty new to DEVONthink and I could surely have made a mistake somewhere, but I have no more clues about where to look/start.

Thanks in advance,

Item counts in DEVONthink to Go and DEVONthink on the desktop have always bugged me. I’ve given up trying to understand the floating and incomplete explanations and documentation, and just ignore the item counts.