Resolved: M1 mini as headless server: Screen sharing issues

Trying to set up an M1 mini running Big Sur 11.3 as a headless server. I can get it to connect using vnc, but the screen is always black.
I switched on screen sharing in preferences initially, but then switched it off and turned on remote management. No matter what settings I choose in either, the screen is always black. No background, no login window, nothing. Note: It works just fine with my existing 2012 mini running Catalina. All minis are connected using Ethernet, but even when trying to connect via WiFi, I get the same result.

Any ideas? Apart from returning the M1 mini and getting another used mini from OWC and living with a Catalina-based server (which would be OK)…

I needed one of these when I ran a headless Intel Mac mini.

1 Like

Thanks, Wayne - I have one of these and that is not the problem. Even connected the M1 mini to a regular monitor - still the same issue. I can connect, but everything is black.

Got it resolved, although I don’t understand how. I finally tried from my corporate laptop, which runs Catalina. I got in without having made any changes on the M1 mini server. After that, I could also get in from my M1 mini desktop. Not sure what Catalina did to make the M1 mini server behave, but it did and I can now connect from all my Macs.

Yep, I got that t-shirt too. I can’t count the times I “fixed” a problem that way.

Glad it worked out. Take the win!