Safari 15 crashing on Mac

Just updated to macOS 11.6 and Safari 15 on my M1 Air. While I’m not a fan of some of the changes to Safari everything was OK until I tried to add a page to the Reading List. Safari crashed as soon as I clicked on the + symbol.

I restarted and tried again and crashed again. I disabled the 1Password Safari extension, cleared history, tried again with the same results. And as an added bonus turns out it also crashes when I try to add a bookmark. Oh well, IOS 15 is looking great.

One crash launched Terminal and filled it with the following info which kept repeating:

~ % /Applications/ ; exit;
objc[3789]: Class _SFAppExtensionsStateManager is implemented in both /System/Library/Frameworks/SafariServices.framework/Versions/A/SafariServices (0x20909cf88) and /Library/Apple/System/Library/StagedFrameworks/Safari/SafariServices.framework/Versions/A/SafariServices (0x1041f8028). One of the two will be used. Which one is undefined.

I updated yesterday, and while it doesn’t crash on my Intel iMac, it occationally freezes the whole system for 20-30 seconds, then returns to normal operation.

Sticking with Firefox, and am expecting an update to Safari shortly.

1 Like

I am also having problems with Safari 15. On clicking links in webpages a new tab opens (expected) and I see a flash of the url in the tab but after a second or so it doesn’t load and the new tab defaults to the start view.

This happens sporadically and sometimes if I try multiple times the page will open on 3rd or 4th attempt.

Happens with all kinds of pages eg news websites, email…

Anyone else having a similar issue?

(Same links open first time in Firefox)

I’m experiencing the same issue, although this started to happen only a few days ago (Update was weeks ago). At first Safari started with the terminal window as described but now it seems to be stuck in some sort of loop. Every “Reopen” adds another terminal tab, Safari icon shows in the dock and then vanishes again and nothing else happens. So far I’ve tried deleting cache and saved state via finder, as well as trying to open it via safe mode. Unfortunately without luck and for now I’m also out of ideas since the whole system is up to date and I can’t really pin it to a specific extension. Let’s hope for a timely fix.

So, I got kind of impatient waiting for an update and had the capacity to test around a little. Long story short: what worked for me was uninstalling all extensions via Clean My Mac X. The last two were 1Blocker and 1Password. At that point, Safari finally showed up again but crashed immediately. Both never caused any trouble but I uninstalled them nevertheless and by accident 1Password, including the helper, completely. After that Safari finally came back up. Up until this post I reinstalled 1Password and everything is back to normal as far as I can see. Hope this helps anyone. While Firefox is ok, all my shortcuts and automation is directed towards Safari. :joy:


I solved my problem by waiting it out. I switched to Brave. And since my MBA is my least used device by the time I tried Safari again, a week or two later, it was working. Nothing had been changed. No updates, no software added or removed, nada. Hazel, Google Drive, and Arq had just been chugging along, sorting and backing up stuff from my iPhone and iPad.

I’ve tried a similar fix on my car (turning up the radio to drown out a worrying noise). So far it hasn’t worked. Maybe ignore it and it will go away is an M1 thing. :grinning: