Security/Privacy doesn't seem to stick

I have this little AppleScript app (a “droplet”, I believe it’s called) that moves files, potentially creating folders and renaming files. Every time I run this, I get this:

I always click OK. In Security and Privacy Preferences, I have this in the Automation tab:25%20PM

and this in the Full Disk Access tab:

So why do I keep getting that annoying dialog box?

I assumed it would go away if you go into System Preferences > Privacy > Automation, and give the app access. (Either that or System Preferences > Privacy > Full Disk Access). Maybe try uncheck the app in Automation, recheck it a minute later, restart and then see if it solves the issue.


I wasn’t sure if you meant “restart the app” or “restart the computer” so I did both. Restarting the computer seems to have solved the problem. I’ll keep watching it to verify. It shouldn’t be necessary to restart the computer to make a preference change apply, though.

@bowline, you might get a laugh reading this.