Setting permissions on backup drives

I’m migrating to a new computer running OS X 10.15 (old computer runs 10.14) and need some help figuring out how to move over the small configurations … Keyboard Maestro macros, dock preferences, Bartender and Better Touch Tool settings.

I made a bootable backup of the old system, figuring I could pull files from it as needed. But when I plug the external hard drive into the new computer, I can’t browse the folders and files. Any suggestions on how to get access?


I assume the backup drive is not encrypted?

Have you tried ignoring ownership? (Right-click on the drive, Get info)

Screen Shot 2021-02-19 at 5.31.09 PM

The original volume uses filevault; the backup drive is not encrypted. Although as a bootable backup I suppose that is a possibility. Will try turning off FileVault and redoing the backup — thanks for the suggestion.

I’ve never seen the ‘ignore ownership’ checkbox — will try that too.


Did it ask for a password on mount? If so then undoing filevault won’t fix the issue.
I think the ownership issue is the problem.

no request for a password on mounting.

Selecting the ‘ignore ownership on this volume’ did not help :frowning:

Neither did selecting one of the locked folders, changing the permissions to allow everyone to read/write. I still get the error message:

Are you logged in with an admin account? I had a similar situation but was able to resolve it following the steps above.

if you look at the info for the folder, can you add yourself as the user?
(sharing & permissions → add user)

And also use the option to apply to files and sub folders (don’t have the exact wording to hand).

1 Like

Permissions can be a problem.

The solution of changing permissions in the Finder has already been posted.

Another option is using chown/chmod in the shell (if you are comfortable with it).

sudo chown -R username \folder

found it! thank you so much!!

1 Like