SideCar issues probably associated with iCloud screwiness

Out of no where, my 2017 MBP 13" with Catalina (10.15.6) started asking me to provide my iCloud password. Every time I entered it, it gave me “unknown Verification” error. The same login worked on and other devices. Long story short, called Apple support and wound up re-setting my keychain and I got back in. But I still think there are corrupted files somewhere. Biggest annoyance is I can’t connect to my iPad Pro 11" 2019 with SideCar where it used to work before. I use this in my WFH workflow. It doesn’t even show up as a device in the Sidecar System Prefs pane.
Did everything it says in Apple Communities - Toggled WiFi, Toggled BT, rebooted both devices umpteen times. I am logged into same iCloud account.

Any MPU’rs have some ideas of where I might look to delete some demon .plist or something?

did you log out and re-logged in from the iPad too? Might be worth a try

1 Like

I did log out and log back in. Still no luck. I am not on VPN, not using Mac as hotspot etc…

NVM - Solved, and I have no idea how.
It just showed up again. Did nothing new.

I think the gremlin just died of old age.

Update: I did do one thing. When I rechecked my iCloud settings on the Mac, I noticed my Keychain setting was not checked in iCloud and re-activated it. I haven’t rifled through my Keychain yet, but wonder if there was some key in there that I needed.


Nope. He’s just off screwing with some other poor iCloud user.