Siri Shortcuts app

Anyone having trouble with the shortcuts app? Every time I touch it, it starts to open and then goes right back to my home screen. I have tried deleting and resetting the phone, even doing a ful restore of the phone. Talked to Apple and they didn’t have an answer other than to set the phone up as a new phone which I really don’t want to do.
Appreciate any help

What iphone is this on?

It could be one of the shortcuts is causing the phone to have issues woth the app.

Have you got another decive that shortcuts does work on? If so, what happens if you remove all shortcuts from that device (back them up first ;-)) and then try to launch shortcuts again on the iphone?

You could try it with the app removed from the phone first, and let it re-sync the empty shortcut list. If that solves the launch issue add one shortcut at a time to see which of the shortcuts causes the problem.

My hunch is that it is a syncing problem, this might solve it.

Thanks, I’m going to try that! Apple has been no help

Did not work. Apple tells me to wait on the next update

I recently had the exact same issue - also in the current non-beta version.
The solution for me was to:

  1. Remove Siri Shortcuts app
  2. Power off phone (I’m on 7 Plus)
  3. Power on phone
  4. Install Siri Shortcut
  5. Force reboot (Sleep+Vol Down until Apple logo)
  6. Power off phone
  7. Power on phone

Don’t ask me why I had to go through all those hoops - but after working through the issue for a couple of hours it worked - might be worth a try.

1 Like

Tony, Thanks for that. It didn’t work for me. On an iPhone X. I’m installing the new update which is basically what apple told me to wait for but in reading the notes it says nothing about fixing crash issues. I’ll see what happens once the update is installed. I’m thinking of reinstalling the phone as new. Of course you know what a pain that will be. Thanks again for the suggestion.

1 Like

Sorry to hear you’re still struggling.
Here’s to hoping the update fixes the issue, otherwise I’d probably go for a complete restore, just for the sake of it🤞

If you’re still experiencing the issue I’d definitely stick to Apple Support