Slow copy and paste in Excel - due to KM, Alfred and Copied

Interesting. Gladys does that also.

I do think that this is a ‘Microsoft on Mac’ issue. I have found it bad with Excel and far worse for the first copy/paste command of the session. It then seems to improve.

Other MS apps also seem to have this problem but to a lesser extent. I am not sure if there is something MS apps are doing in the background when they first access the clipboard part of the OS?

This was what Peter Lewis, developer of Keyboard Maestro said in KM forum. So, you are all correct. It is a MICROSOFT thing.

This is covered elsewhere. Since Microsoft decided that it would be a good idea to make available an image of anything you copy in about twenty different image formats (including very expensive PDF) every time you copy anything, and since Keyboard Maestro records the clipboard faithfully, there is a lag. Either Microsoft will have to change this, or you will have to exclude Microsoft apps from the Keyboard Maestro clipboard history

1 Like

Yes, I have LaunchBar as well. I will see if I can disable that for Office apps.

Since Excel is creating all these image formats, it should be irrelevant whether a clipboard manager is running. My guess is the machinery to do the copy is in a library that is loaded on first use. Further speculation is this is done to make Excel load faster initially.

1 Like

Success! I’ve disabled the Clipboard on Launchbar (as well as Keyboard Maestro) for Office applications and can confirm the copy/paste function operates instantly.

That’s a long-term annoyance that may just have been solved!

3 Likes

Microsoft apps, in general, seem to do strange things related to the clipboard. When I was using OneNote (which I don’t any more) I had trouble with TextExpander because OneNote took so long to “paste” that TE had often swapped the clipboard back before the snippet got pasted (TE works by saving the current clipboard, putting the snippet on the clipboard and doing a paste and then putting the original clipboard back.

I do run Copied and that might be part of the issue, but no other apps seem to have a problem with that.

I notice that even in Excel I get really slow cut and paste most, but not all, of the time. If I am doing a large copy in Excel I sometimes have to turn off Copied.

It doesn’t occur for me. I just opened a file with multiple vlookups, around 100,000 records and which contained a lot of modifications to test it this would occur for me.

I tried a few copy and pastes and the first and all subsequent had zero delay or any sort of beach ball.

I guess Microsoft software is a bit inconsistent depending on your setup.

Just tried Giphy Capture and the cmd+shift+5 screen recorder, neither capture the beachball, and just show a pointer.
I’ve quit everything that should be involved with the clipboard, including Keyboard Maestro.
Open Excel, type a number, copy the cell, move off, beach ball. Every first time after Excel is opened.
Tried turning off all the Cut and Paste options.
Not something I need to solve at the moment.

@Topre Thank you! That seems to have worked. Small sample size but I am reasonably sure it was the KM issue…thank you for posting instructions from KM developer on how to fix. I am a big KM fan for my iMac. I was instinctively blaming MSFT…which I suppose may still be appropriate…interesting to find out it was a KM clipboard issue.

UPDATE/CORRECTION: re-read your post as instinct to blame MSFT is usually a good one…in fact it does seem to be a MSFT-driven issue with Copy to Clipboard that is revealed when using KM…appreciate KM coming up with a solution.

1 Like

I’ve had this issue for months as well. I don’t know exactly when it started but same symptoms. Beachball for 5 or 6 seconds on the first copy in Word, Excel and PowerPoint but generally fine once you get the first copy and paste out of the way. I only ever use cmd+c and cmd+v for copy and paste.

It definitely seems to be some interplay between MS apps and Keyboard Maestro. I just restarted my Mac, shut down Keyboard Maestro, and fired up Word. Copy and paste is as fast as it should be.

Has anyone found a good solution to this issue?

OMG - this has been bothering me for YEARS! So happy I finally found the answer!

1 Like

FWIW this problem recently disappeared on my iMac Pro. Dunno why.

I think the latest version of Office corrected it. I noticed it was gone too.