SOLVED ✅ Bug? Reminders Date Monterey

UPDATE I discovered the problem. I had changed the format of dates in preferences for an Alfred snippet I created (Alfred uses the preferences formats for date placeholders). When I changed the date formats back to default, everything worked properly in Reminders. There is either a bug between the interaction of date formats if changed and Reminders or I had a mistake in my format syntax. I’ll experiment but the issue is resolved for now by returning to default date formats.

I think I found a Reminders bug in the latest release of Monterey. The due date showing up on the left panel is inserting an extra number. Every task with a date as an extra–but different–number. The extra number does not show up in the information/details panel. This bug does not appear in iOS/iPadOS. Below is a screenshot.

Is anyone else seeing this bug in Reminders in the latest version of Monterey?

I’ve rebooted the MBP but that does not resolve the issue.

Does the reminder still work?

Mine displays dates as MM/DD/YY and it displays correctly. I didn’t even know you could change the date format.

Yes, the reminder works. And, what seems to be happening is that the / is moving one number to the right, for example:

20222/14/ should be 2022/01/14 for Jan. 1, 2022

That has me thinking–I changed the default date format in preferences a few days ago based on a snippet I created in Alfred. I’ll reset the formats to default to see if that solves the problem. If so, it is still a bug. :slightly_smiling_face: