Solved - Issue with a workflow launched from the widget/Today view

Hi everyone,

I am requesting your help because one of my workflows is driving me nuts… :crazy_face:
It works well from the app or from the Home screen. But it does not work when lauchend from the widget in Today view.

The purpose of this workflow is to:
1-Send a message to my wife when leaving work to inform her of my arrival
2-Open Waze once I clicked on the send button

Here is how it is configured:
1-Street Address
2-Get Travel Time
4-Send Message
5-Open App

Do you have any clue to explain this behavior?

Thanks in advance

Where does it fail when launching from the widget?

It seems that it freezes from the first step.

When launched from the Home screen, it’s really quick to access directly to the message.

But when launched from the widget, it jumps to the workflow app. And there, nothing is happening.
The workflow is launched but there is no progression.

Hmm. Can you share the workflow so I can try it out?

Thanks Jason.
I will share it tomorrow.

As explained, it’s a simple workflow:
1-Street Address, with my home address
2-Get Travel Time, from current location ; transportation mode = Driving
3-Text, using the ´Travel time´ variable
4-Send Message, with my wife as contact
5-Open App: Waze

Franck silly me I just realized I have almost the exact same workflow minus the Waze part. I added waze to mine and it still works fine regardless of where I activate from. Have you tried recreating the workflow. Wondering if it’s just got a glitch somewhere. Or maybe removing and adding as a widget?

I already tried to recreate the workflow. And if I well remember, it didn’t fix my problem.
I am going to test this again.

So, I created the workflow from scratch -> didn’t fix the problem.
But… I tried using 'Contact" instead of ‘Street Adress’ for the 1st step, and it works! :grinning:

Thanks for your help

That’s odd. Seems like a bug. Submit a feedback maybe?