SOLVED: Recreate “Append to Evernote Journal” action in Drafts with DTTG2

UPDATED: Solved:

Has anyone figured out how to recreate the “Append to Evernote Journal” action for DevonTHINK 2 GO in Drafts? I have been tinkering without success. I can start in Workflow or Drafts.


Make sure the document:

  1. Is plain text (RTF won’t work)
  2. Has some text already in it.
  3. Use the UUID only. (don’t paste the x-devonthink-item:// with it)

You can do this by creating a new action in Drafts with a URL scheme:

In DTTG2 find your journal item and log press on it and Copy Item Link. Go back into Drafts and remove the preceding x-devonthink-item:// leaving only the string of random letters and numbers. Copy that string and place it in the above URL where UUID_OF_JOURNAL is, make sure you don’t add any spaces when pasting, then in Drafts create a new action, in the steps select URL and paste the complete URL in, try running and it should work.

Thank you for your help. I did everything here and while Drafts returns a success, I get this picture when it goes to DTTG and nothing is added to the text file. I triple checked that the UUID was pasted without error or space.IMG_08A264A90E23-1

I was only able to replicate that error when I didn’t have any text in the Draft, or if I had used the [[body]] tag and only filled out the title (first line).

Can you share the URL you are using?


It is a plain text file with two lines of text already written and saved.

Okay the URL should be:


The x-devonthink-item:// item needs to be removed as you only need the UUID, try copying the above URL in the Drafts action and try again.

1 Like

It worked!
I tried that first, and it gave me the same error, but now I realize the document was empty when I tried it. So I put the x-devonthink-item back in, and then entered text. I did two things at once instead of de-bugging one step at a time. rookie mistake, which just fine for this rookie.

@joshsullivan Thanks! This has been very helpful!