Spotlight indexing stuck- have tried everything!

Happy New Year to all! I use Alfred to search for files in my 12" MacBook, and noticed a few weeks ago very little was coming up. Long story short, I’ve tried to force reindexing Spotlight in every way I could find:

  • Add, then remove hard disk from the Spotlight privacy prefs

  • Used Onyx/ CleanMyMac

  • Used terminal commands:
    sudo mdutil -i off /
    sudo rm -rf /.Spotlight*
    sudo mdutil -i on /
    sudo mdutil -E /

  • Even did a clean install of the Mojave OS and tried above again after restore from backup.
    After 24 hours of Spotlight indexing, I can barely see that a tiny sliver of “green” is showing in that Indexing bar when using Spotlight. Activity Monitor shows several MDworker files.

Any help/ thoughts appreciated at this point. I can’t even search Mail and find previous emails! Either re-indexing seems to be stuck on something, or I haven’t given it enough time (and would take weeks at this rate!)- thanks!

First, have you confirmed that it’s a Spotlight problem by using Spotlight itself to do searches?

If so, how about trying the simple way to get macOS to reindex your drive:

(1)
Spotlight > Privacy

  • Add your hard drive to the list to “Prevent Spotlight from searching these locations”, either with the ‘Plus’ button or by dragging the drive icon from the Finder.

(2)

Quit System Preferences, wait a few seconds, then

(3)
Spotlight > Privacy

  • Remove your hard drive from the aforementioned list.

And, as always, a restart never hurts.

That’s the first thing they said they tried :wink:

Correct- that was the first thing I tried, and yes, it is definitely a Spotlight indexing issue as noted- thanks.

I am in the same boat. Have you figured it out?