Stupid Beta Mistake - any tips on rolling back?

So… I managed to forget that I was enrolled to the Beta Program for Apple on my MacBook Pro. So when I finally went ahead to upgrade to Catalina, I ended up on Beta 10.15.1 19B77a.

This seems to be a bit of an issue since Dropbox is going BANANAS on this Build. Continuously re-indexing and making my machine work at max capacity…

It seemed that this should be easy to fix, by going off the “Beta” program and then searching for a system update. No such luck.

Is there a way to roll-back the OS without having to go via a full restore from Time Machine - and THEN re-upgrade to Catalina…?

Opt out of the beta:

Subsequently, go to the Appstore and try to download Catalina. This worked on the GM version, not sure if it will help with the new beta version.

If the downgrade in place suggested by @TheMarty doesn’t work, you could try making a bootable thumb drive, booting from that and installing over your existing installation.

1 Like

Yeah, this is what I tried. Didn’t work. So I started a restore via Time Machine. And how awesome this is going. It fails towards the end with an error that it can’t restore some file (at the very end of the restore). This is after it has erased my drive of course. So happy times.

It suggests that I reinstall the macOS and use the migration assistant for my files… HEH That’s going to suck quite a lot I guess since all my settings will be dead.

Sooooo… trying a restore from an older Time Machine now, and crossing my fingers. :smiley:

So, the error I am getting is:

“An error occurred while restoring from the backup

Try restoring from a different backup or reinstall macOS and then transfer your information from a Time Machine backup using Migration Assistant”

Could this be because the backup is on Mojave and the Mac currently has Catalina installed?

So this is fun. Checking the log it seems that some file in my iPhotos Library causes it to crash.

Any ideas on how I can actually just delete something from the Time Machine and try again?

I can delete the whole iPhotos Library (as I’ve got it backed up elsewhere anyway), but I’m not allowed to do this…

Does Migration Assistant allow you to do selective restores?
I seem to remember it does.

Not sure. Waiting to find out. Trying to actually get a macOS to work on it now. The first clean install from Recovery Mode failed.

I have never been this furious at Apple before. Building a Time Machine solution which is this frail is crazy.

It’s ONE FILE in the Photos-library that it has somehow messed up. But I can’t manage to delete it, and instead of just skipping it and letting me know it was skipped… the Time Machine setup is all useless and breaks my machine.

(I realize this is my fault with the Beta thing, but I assume that my Time Machine would have been just as useless to restore from for any reason.)

I once restored my OS from Time Machine and it failed. Since I had an online backup, I just reinstalled the OS and once I logged in all my files were in place. So maybe the Time Machine does not really fail.

I guess that potentially it has sort of worked out, but as of now it’s throwing an error when I try to reinstall macOS. So I have my doubts.

Currently creating a bootable disk for installing Mojave. :smiley:

I think a lot of people will never again run beta on their working machines :slight_smile:

1 Like

I think so too. :stuck_out_tongue: Luckily my iMac is all good and cozy on Mojave, and my schedule has allowed me to not be dependent on my MacBook today or for the next couple of days.

But I could have spent my time doing more fun stuff than this… and I don’t really know when it will sort out properly.

1 Like

So, I created a bootable install disk for Mojave. I get to select it on startup. I get to connect to WiFi, then I get a progress bar.

At the end of the progress bar the screen ends up with this…

Any suggestions? :unamused:

Never heard of this site before, but DuckDuckGo came up with this for “-1008F”:

1 Like

I need to remember using Duck more often. I came upon a Reddit Page with something similar, but your suggestion has a lot of tips for things to check once I get out of this nightmare! (And I unenrolled and started a new recovery which isn’t hitting the error now.)

Sounds like you’re trying to boot from the internet?
Using a bootable thumb drive, you should be able to boot from the thumb drive itself, then install from the thumb drive. This takes the internet/network out of the possibilities for failure.

This is probably some Catalina-type bug. So once I managed to unenroll from the Beta Program via the website, I got past the initial boot thing, and then I managed to get into Recovery Mode Utility Disk, delete the disks (which had become a big mess), then restart and start the install of Mojave… keeping my fingers crossed that this will actually work. :sweat_smile:

1 Like

Yeah, let’s hope so!

I rebooted my laptop while ago, and it was like setting up a new computer, dock was set to default apps, had to enter license codes for several apps, etc. I was almost positive I had rebooted after installing Catalina. Very strange.

1 Like

Didn’t go that great. :smiley: Every time I tried installing Mojave, it hit the stupid 1008F error… in the end I got a new round of disk delete done, selected to start installing Catalina via “reinstall macOS” in Recovery Mode, and went to sleep.

This actually managed to complete, and it had me back on the released Catalina, not any Beta. During the install I could select to transfer everything from the Time Machine (there was a different file that failed to transfer, some receipt for an Apple Store bought App it seems, but this didn’t cause the process to crash). Now I’ve got it up and running and it’s going through all the “get this data that has been added to actually work”-process, like “importing” the data into Mail and Photos, syncing and indexing Dropbox, and so on.

Will be exciting to see if this turns out OK or not. HEH

1 Like