Swipe to Archive on iPad, swipe to Delete on iPhone? How?

Hello all - any suggestions on where to change this?

On the iPhone, for reasons unknown to me - I have ‘Delete’ as an option in Mail.app - and as such, it is there for me on swipe-left**.

On the iPad, also in Mail.app, with the same accounts etc. as over on the iPhone, it’s not.
Why is there this discrepancy, and where to do I set it, so as to also have ‘delete’ (rather than ‘archive’) available on the iPad?

Can anyone help?

** I have always been confused with the ‘swipe’ terminology. Just me?

If I hear/read/say ‘swipe-left’, is that in reference to the direction of the swipe – i.e. I am swiping from the right side of the device, to the left – or is it in reference to the origin point of the swipe i.e. I am swiping from/on the left-hand-side of the device/view/pane?

@BradG, Your questions will be answered by looking at “Settings -> Mail -> Swipe Options” on each device.

1 Like

In Settings > Accounts > your email account > Advanced, set the “Move discarded messages to” to deleted and that should fix it.

Thanks @RosemaryOrchard – that was it – wouldn’t have thought to check all the way through to find the ‘Advanced’ option (although I obviously found it somewhere in the mists of my previous iOS iterations over on the phone!).

Thanks @rkv – I looked there, but the ‘Delete’ option wasn’t available. Needed to switch to it under the Accounts/Email Account/Advanced setting, as per @RosemaryOrchard’s suggestion.

1 Like

That said - if anyone is willing to explain my confusion around the “swipe” conventions, will be most appreciative! :sunglasses:

Posting this for future reference.

I was having this issue with an iCloud domain and the steps didn’t line up (they worked for non-iCloud accounts). I found this setting through the following taps:

  • Settings
  • Apple ID
  • iCloud
  • iCloud Mail Settings
  • Advanced
  • Move Discarded Messages To: