Text replacement syncing woes

I have an iPhone and iPad, both on the latest version of iOS. I had the iPhone first and then got an iPad a couple months ago. In the beginning the built-in text replacement was syncing across the two devices properly. But they stopped syncing a few weeks (?) ago.

I have a macOS device on the same iCloud account which is still on Sierra. I read that the issue has been fixed on iOS 11 and High Sierra, because Text Replacement now uses CloudKit. I don’t care if the macOS syncs properly or not, but is it possible that the older version is holding back the transition to CloudKit on my devices?

Any ideas for how to sync the two iOS devices correctly?

(I read some folk remedies on the interwebs, but nothing I tried has worked.)

No ideas? :frowning:

Does your text replacments sync between your Mac and your iPhone and/or your iPad?

No device syncs with any of the others. Each device has its own entries, based on what I needed to do on that device.

In order to isolate your issue, I would start by taking these steps:

If you have a good list on your Mac, you can just export by selecting all and dragging into a Finder folder or your desktop. To import again later, just drag the file back to the text replacement preference pane.

Then, erase all replacements from all other devices. Make sure to reboot and ensure latest running iOS version and macOS Sierra (not High Sierra) version. Also - sign out of iCloud on ALL devices, and sign back into them again.

Add one text replacement manually. See if it syncs.
If not, try testing in another user account on your Mac. Does it sync?
If not, try in safe mode (holding shift while booting). Does it sync?

Looking forward to see how it does.

1 Like

Thanks Petter for the advice.

  1. I removed all replacements from my iPhone.
  2. Now the iPad and the Mac sync correctly (I tried adding replacements in both and they appear near instantly in the other).
  3. I signed out of iCloud on the iPhone, and then back in, but it’s still not syncing.

Should I follow your original advice and nuke everything or is there a way to jot the iPhone into syncing?

Ok, interessting.

You can try to sign out of iCloud on your iPhone, make sure it’s updated, reboot it and sign into iCloud again. Does it sync? :slight_smile:

I did try that on the iPhone and it didn’t sync. I logged out of both the iPad and the Mac (and logged back in again) and now the Mac doesn’t sync :frowning:

Okay, but it might seem like the iPhone is the issue here.

Take a backup, then restore in iTunes. Set up as new and see if it syncs. If it does, consider taking your backup back and see if issue still is there.

Regarding backups: it’s not as important now a days to actually use a backup, as most content is SYNCED, not backed up. Example: if you have iCloud Photo Library turned on, restoring the iPhone with NO BACKUP would not loose access to your photos, they would re-appear as soon as you sign back into iCloud with your Apple ID credentials and turn on iCloud Photo Library. For a comprihensive list of the small things that is still backed up, not synced, look at this knowledge base article from Apple:

This is so weird. The iPad and the Mac are out of sync, and after another restart the Mac has synced the iPhone data that I erased about 10 minutes ago!

Edit: I think I’ll leave things for tonight. Maybe things are syncing back and forth :slight_smile:

1 Like

After all the voodoo above it looks like text replacement syncs across my three devices consistently! Thank you for the help @petterhol :pray:

Let’s just hope it lasts! :crossed_fingers: :sweat_smile:

Good to hear, retain screenshots or any other documentation you have from this time, in case it happens again! :slight_smile:

1 Like

I did screenshot the replacements on all three devices before beginning to wipe them – although I ended up wiping only the iPhone. I actually didn’t have that many replacements, precisely because of the syncing trouble. I’ll now be sure to make more use of this feature. Unless I finally throw in the towel and pony up the monies for Text Expander :money_with_wings: