The frustrating inexplicable “hiccups” with technology

Technology-for all of its benefits-sure can be frustrating! For no explicable reason that I can determine, MyFitness Pal is refusing to read today’s exercise, at least the majority of it. I changed nothing in any of my settings. The Health app accurately reflects my activity but not MyFitness Pal. I’ve toggle off and back on all relevant settings in both MyFitness Pal and the Health app on my phone and watch. Still, MyFitness Pal will not sync over the activity. I deleted and reinstalled and re-synced MyFitness Pal. Nada.

From Health App:

From MyFitness Pal:

Screenshot 2022-06-10 at 9.47.22 AM


I’ve got other things to do besides “fixing” app problems that just appear for seemly no reason. :confused:

1 Like

Have you tried to switch it [your iPhone] off and on again? :blush:
(Sorry that just came to mind as I had been watching IT-Crowd again recently :sweat_smile:).

But really, I figured it solved some of my frustrations and that of my wife with our iPhones like total crazy auto-correction, the infamous iCloud sync or other oddities. But I agree … I have better things to do than fixing app problems … especially in private IT life (I just finished a 6h trouble shooting session on some SharePoint servers that’s part of my job :sweat_smile:)

I never liked Sharepoint as an end user! :slightly_smiling_face: After switching every switch I could think of I did my usual hard reboot. Still not syncing correctly. Go figure.:slightly_smiling_face:

I had that the other day, where Garmin refused to sync with my watch. It then proceeded to suck all the battery using god knows how much CPU of the phone (it was hot) before I realised and force quit it.

Have you checked if MyFitnessPal has a problem today? I had a problem with them for a few months (ages ago now) not syncing with apple data and their response was that they were aware of the issue but had no projected date of resolution :roll_eyes:

Sure enough, that’s it! I never thought to check for downtime or other backend problems. I just assumed it must be a problem with one of my devices or apps. Thanks for the tip!