Time Machine suddenly doesn't recognise external HD format

Hello all

I wonder if anyone has an idea about this one. I’ve been using the same backup drive (WD Elements spinning disk) on my trusty MBP 2015 for at least two years, but as of yesterday Mac OS (10.15.7), which I’ve also been running for a while, thinks the drive isn’t’ correctly formatted to journaled (extended). Nothing has changed – I’ve ran successful TM backup for months on exactly this setup. I see that the disk is getting full, but I thought that TM managed its own space needs.

Before I replace the drive, is there anything I could do? I’ve tried a reboot, physical dis/reconnect, and First Aid through Disk Utility, which have made no difference.


It seems, that there might be something damaged with the filesystem of that disk.
Can you access the files?
Do you have an other Mac available somewhere? Can you access the files from there?
Is FirstAid running without any failure?
Have you changed something with your power saver settings (Hard Disk to sleep?)?

You could consider a erase and new setup for the disk, BUT if you can still access the data on this disk, those data will be lost by the erase!!!
If you go with the erase, I would always (if it is offered in the setting) do with a save erase with a number of runs. I’m at this moment not sure, how many runs you need at the minimum for that, but if it runs the required times the erasing process, FirstAid will isolate possible fault areas on the disk, so you can “rescue” a disk with a damage to some sectors by that.
If there are some bad sectors on the disk, you should consider a new one for TimeMachine anyway, and to use the old disk only with data, that is not that importand, if lost.

1 Like

If you click the Time Machine icon in the menu bar can you then click “Enter Time Machine” and access the Time Machine drive that way?

In my experience, Time Machine throws off mysterious and often erroneous errors. And, unfortunately, Time Machine often gets to a point where it just irremediably breaks. A call to Apple Support might help.



Have you tried a different cable?

1 Like

Thanks to all! I didn’t have another cable handy (it’s one of these weird connectors in two parts); could still access all the data through the TM app or browsing it through Finder; and disk First Aid completed without finding errors; but the error message persisted.

I ended up erasing and reformatting the drive and am now building up a new TM back-up from scratch (with 429GB this is looking to take a merrily long time indeed…). I rely on the backups as a backstop but don’t routinely need to recover anything going back a few months, say, and the MBP is largely synced with another Mac at work which runs its own TM and a clone, so I have lots of redundancy built in. So a brand new local TM suits my needs. Anyway – thanks for all your tips!


Well the plot thickens.

So when my original problem occurred I reformatted the HD and reloaded a brand new instance of TM. Fine. It worked for 2 days, then same error.

So I bought a brand new HD, new cable (Lacie Mobile drive that’s optimized for Mac), once more reloaded the TM. It ran without fault for several weeks. Until yesterday. The same error, despite First Aid running without faults:

So it’s pretty much certain that my external HDs are not at fault and that Mac OS Catalina is making my life harder. Is it possible that the TM codebase can corrupt, or something? I’m out of ideas, and would be very grateful in case anyone has any further thoughts on how the OS installation itself could be at fault.