Trouble getting started with Workflows

So kind of new to the Workflows app and decided to start using it recently. Running into a couple problems trying to make my first workflow.

First, I use the app PDF Pen to fill out a new form approximately 3 times a day called an FLRA. What I’d like to do is save it using a specific nomenclature, and in a specified folder in dropbox, then attach that file to an email using the same name (minus the date time) in the subject line I’m not even sure if this is possible because I’m still stuck on step one of just saving the file.

I’ve started by using:

Set Name: Current Date/Time Clipboard FLRA (example: 2018-07-22 1747 Text on Clipboard FLRA)
Save File: Service:Dropbox, Destination Path:FLRA (FLRA is a sub-folder in the parent folder Dropbox)

I’m signed into dropbox but I’m still getting this error message:


Not sure why I’m getting this error, tried troubleshooting by trying a few different things like switching the order of Set Name / Save File, also tried signing in and out of droppox for example, still stuck.

Any advice from someone more experienced would be greatly appreciated.

I think you have to put a slash in front of your folder name. So /FLRA should work.

Thanks Craig, giving that a shot now

As a developer invalid_access_token/ immediately has me thinking it’s your login the Dropbox that’s not right. When you sign in to Dropbox Workflow gets a token to access your account with. This is so the app doesn’t need your actual Dropbox password. You can remove access from any app on Dropbox without changing your password. The token gets invalidated.

Try removing access for Workflow on the Dropbox website and then signing back in on the Workflow app again.


Wow, forgot I posted this but you were 100% correct. I had given workflows access a long time ago and since that time I updated my dropbox password, and possibly changed phones so even though the workflows app showed I had access, dropbox wasn’t actually allowing access.