Universal Control is now fixed

If your universal control stooped working recently, just after the last Mac OS update, you’ll be delighted to know that the latest update (which is just out) seems to have fixed it.



Hi. I too thought it had solved it, but this morning it just doesn’t work again :frowning:

Fully updated on all devices, restarted everything a number of times, all to no avail. Switched on and off both iMac and iPad settings, checked Firewall (off) again nothing.

I can extend the display, so the iMac is ‘seeing’ the iPad, but UC is just obstinately refusing to play.

Any ideas?

Nooooooo :scream:
Nooooooo :scream:
Nooooooo :scream:

I’ve been using UC with two Macs and an iPad all day, and it works perfectly. I would try and troubleshoot local issues as it can function flawlessly with the latest updates.

An update…

I tried to coax it into working by seeing if my other iPad (I use it primarily with a Pro, but have a Mini too). Didn’t work but then lo! The Pro began working :blush:

I tried to see if it was ‘local’ as suggested-rebooted router, switched all settings off and rebooted, switched on etc.

Not sure what clicked into place, but will continue to monitor with :crossed_fingers:

And my Universal Control between 2 Macs (iMac and MacBook Pro) stopped working today after being flawless for nearly 2 months. Ugh. I am so dependent on this little piece of Apple magic.

I’m hoping that if I do the reboot and setting on and off dance one more time, it will come back, but in the meantime I am very frustrated.

Latest OS on all devices.