Updates overnight — things not working right today!

Hi all. Something updated last night on my laptop. But I’m not sure what. I thought I’d hit “remind me later” but I must have hit “update tonight” by mistake. I’ve noticed two things (so far) that are really screwing with my workflow:

  • 1Password isn’t working with Safari. I have to launch it separately and copy and paste passwords (I’ve reinstalled 1Password. Still no-go).

  • My touchbar isn’t working with Mac Mail app. I typically use a shortcut I’ve set up in Better Touch Tool to file mail, but even the default tools aren’t working. I can see them on the touchbar, but when I hit the button nothing happens. The touchbar does work in Safari and other places, but not Mail. The touchbar is also working as expected in Keynote, fwiw.

Any ideas? Thanks!
Doty

My 1Password was doing that for me this morning too. I ended up quitting safari, quitting 1 password completely (using the menu bar option), and restarting both (I forget what order) and it seemed to fix it. Maybe worth a shot?

(No advice on the touch bar).

Well, they pushed out an update in the App Store, but I’ve tried twice and I’m getting this error. I’ll try again later. I have no idea what to do about the touchbar

Missing info: you updated from what to what?

1 Like

This may help you with the TouchBar

https://9to5mac.com/2020/01/20/mac-how-to-fix-and-restart-the-touch-bar/

Recently, the App Store is really problematic. If I look at the updates area of the App Store and see some are ready for an update, I get errors such as “unable to download update” etc. I find just hitting update button again…or again…lets it complete the update.

I believe there are other conversations here that complain about the App Store issue.

That’s the problem, something updated overnight and I have no idea!

Is there a way to look and see what was updated and when? If it helps, the Big Sur update did not happen. I’m still on Catalina 10.15.7. I’m guessing it was security updates and Safari looks different so probably a safari update as well. Possibly more.

I tried what that article suggested and I got a “-bash: sudokillall: command not found”

Your computer knows.

Click the Apple icon in the menu bar. Open About This Mac… and choose System Report. Scroll down to Software > Installations for the full log of what was installed, when, and if it is an Apple installation or not.

I’m not sure what worked, but after the Terminal fail I described above I restarted and it worked. The App Store is still failing and I can’t download the latest 1Password. But hopefully time will fix it??

That’s an App Store bug that happens with a variety of apps from time to time. I’ve found retrying multiple times in a row often gets it to work, but it can take 6 goes or so.

3 Likes

I’m not sure what happened with 1Password 7.8.1 but I ended up just rebooting to get things to work right again. I think some part of the previous version of 1Password did not fully quit during the installation process. Can’t remember having to do that before, but everyone’s allowed a glitch occasionally.

I’ve been trying to download a Day One update since April 6. No matter how many times I try and how many times I reboot the computer, I still get the error message saying that it can’t be installed. I’m thinking that uninstalling the app and reinstalling it is the only choice I have left. Any other ideas?

I had the exact same thing with Day One a month or two ago. I could get others to work after repeatedly trying, but not Day One. Then one day, it worked. No rhyme or reason to it.

I have this problem with other apps updating, but Day One is the most frequent one to have it.

I would try to ignore it until after we get the macOS update next week.

“Glad” :slight_smile: it’s not just me.

My Mac mini running Mojave runs into this all the time. It’s gotten to prevalent and so consistent that if an app doesn’t update on the first try, I just delete and reinstall.

1 Like

Day One had another update on April 15 and that one installed immediately. So I’m now up to date with Day One, but I wouldn’t be surprised if it happens again based on your experience.

Thanks. I think I’ll do that in the future. It would probably save me a lot of time.