USB3 hard drive not recognised by M1 MacBook Pro

I have a “3.0TB OWC Mercury Elite Pro With USB+1 Storage Solution” that I bought in late 2015 that was for many years my iTunes library drive. For the last year or so I’ve just had it turned off but decided today I would wake it up with a view to repurposing.

The problem is my M1 MacBook Pro utterly refuses to recognise it as a hard drive. It does show up in the System Information app on the USB bus, and this is true with the many different ways I have tried to connect it:

  • USB3 cable (as supplied with the unit) to OWC USB-C Dock (USB-C to MBP)
  • USB3 cable to StarTech USB3 travel dock (USB-C to MBP)
  • USB3 cable to Apple (USB2) multi-port adapter
  • USB2 (B-to-C) cable direct to MBP

I don’t have a USB3 B-to-C cable to try. Note that the drive shows up on the USB bus in System Information with all of these connection methods, but never in Drive Utility. Note that this drive has external power and on/off switch and reliably spins up when I turn it on.

I then plugged it in using the USB3 cable to my Mac mini (where it used to reside in its working days) and the drive shows up in Finder straight away.

I have a feeling I encountered problems with another device that would only work with certain methods of connection but I think that was a bus powered drive and I was able to make it work through the StarTech dock.

Any thoughts? I’m getting the feeling it’s an M1-USB “thing”.

I’d try OWC Customer Support. From everything I’ve heard they are very responsive.

1 Like

I would think you would see something in Drive Utility if this was the case, however just in case a long shot pays off… The drive isn’t formatted as NTFS is it? Perhaps in the distant past you installed something on the mini to allow it to manage NTFS formatted disks and need to replicate that on the M1?

Thanks that was not something I had thought of. But alas no. It’s a GUID partition map with a single HFS+ partition. Time to head to OWC support.

Ah - well, it was a long shot! :wink:

Hope support gets you back up & running!

I gave up on this drive, opened the enclosure and simply took the drive out and put it in my drive ‘toaster’ instead. The drive itself is too noisy to leave running all the time anyway.

Here’s the fun follow-up though. I have a 960GB SSD that I’ve had for years and used to be inside my 2011 MBP. In recent years I’ve used it with a Seagate portable drive connection thingy (it came with its own drive but it’s just a standard SATA connector). No problems. Until I was given a nifty little USB3 enclosure recently and decided it would be the home for this SSD.

I plugged it in at home and moved data to and fro no problem. This, I thought, will be the device I carry in my bag as a portable drive on-the-go. First time I went to use it away from home, I plugged it in, the little light flashed away rapidly, and the drive never appeared in Finder nor Disk Utility.

Eventually a sense of deja vu crept in that I’d had this problem before. Except I realised it was another portable drive, not the OWC one, that had given me the problems. And then I remembered how I solved that problem.

I can plug the SSD directly into the Thunderbolt 3 port on my M1 MacBook Pro and it will appear on the USB bus but not as a drive. If I plug a cheap StarTech USB-C dock into the MBP and the drive into that, it works perfectly.

I wonder now if this was the problem with the OWC drive, too.