WatchOS 7 changes?

I have fallen off the wagon for watching Apple events.
Have I missed something? I upgraded to WatchOS 7 and none of my watch faces have a calendar date. Was this removed? A bug?
Between kids and COVID, I have little brain cells left to see what I’m missing. Help me, external brain; you’re my only hope.

1 Like

The calendar complication can be added to any number of faces. There’s no problem I see with this in Watch 7.

Either configure your face and complications on the watch, or use the Watch App on your iPhone to edit faces and complications, save them, and configure as the current face for your watch.

Well… Such has been my historic experience as well. But … all of my existing watch faces have lost their calendar complication, nor do they show the calendar complication on the watch when you go to edit. Further, when I go into the watch app on my iPhone, it is not listed.

There were no problems when either update (WatchOS and iOS).
Any further ideas?

Try shutting down the Watch completely then restarting it. There might be a config issue with the data transferring from the phone to the watch. Restarting the phone at the same time might be helpful.

I’ve read of data transfer issues with Watch OS 14 and the reboot advice.

Neither worked. Naturally, if it’s a simple error in the installation, I can/will try a re-install of the whole OS. That being an acknowledged option, I’ll see if anyone else notices a similar issue.

Are you using the built in calendar app? If not, try removing it from the watch and re-adding the 3rd party app you use?

I wasn’t using any 3rd party app. It was the OS’s built in date function. I suppose, presumably there was a default calendar.

Animations and transitions are faster in watchOS 7, right? The jump to the app list in particular feels timed better.

1 Like

Seems that way; time will tell.

Since I upgraded to watchOS 7 my Apple Watch is no longer unlocking my iMac running Mojave.

If you haven’t tried, I would recommend going into Settings - Security & Privacy - General and toggle off then on the “Use Apple Watch to unlock apps and your Mac”. Close out Settings and try again. If that doesn’t work, try logging out/in then rebooting.

I seem to have to do this every once in a while; sometimes it’s random but more often than not after patching or an OS upgrade on one device or the other.

According to this K-Base article, you also need to make sure:

  • Your Mac has Wi-Fi and Bluetooth turned on.
  • Your Mac and Apple Watch are signed in to iCloud with the same Apple ID, and your Apple ID is using two-factor authentication.
  • Your Apple Watch is using a passcode.

BTW, I had too do the above dance but it’s been working solid on two Catalina machines since.