Weird Wifi Issue

Not sure what’s happening.
15" Macbook has been fine been running Catalina for 2 months.
Got a notification that there was a new system update, so I updated. (Now on 10.15.3)

Ever since the update, wifi has been extremely annoying.
Connection drops every 10 minutes, when it tries to reconnect, it keeps asking for the password every single time (treating it like the first time to see this network)

The only solution I have found that works almost instantly…is to turn the wifi off and then on again from my Apple Menu bar settings.

Thoughts? (fyi, nothing in my network setup has changed at all, no movements, wires, etc)

Create a new network profile and use that one

If that doesn’t help:

System preferences > Network: select WiFi
Advanced > remove WiFi network ssid(s)
Done > Apply
Reconnect to network by entering wiFi password again.

If that doesn’t help:
Applications > Keychain> Search for the SsiD (WiFi name) and delete.
Restart Mac

@Wolfie @MacExpert

I tried all the options provided. Same. Works for a bit, disconnects, has a problem re-connecting on it’s own, until I physically turn on/off wifi from network settings.

Here are some other things you can try that might help to narrow down where the problem is:

  1. Test with a different user profile.
  2. Reboot in recovery mode and try to connect to the wifi from there and browse the web
  3. On your router create a new WiFi network with a different SSID with WPA2 encryption

So I hd a similar issue. Is it possible your wireless access point can’t handle that many devices connected to it? Upgrading to an eero 18 months ago seemed to have solved my problem with this, which Apple devices seem to be more susceptible to this issue.

Restart the router to refresh the DHCP server

This might be worth a shot.
Some people in the comments say their problems persisted through OS reinstalls, but these steps cured the problem.

Also, I don’t suppose you have anything installed that would fiddle with the network, such as TripMode? LittleSnitch? Proxy? VPN? Keyboard Maestro?

Have you run Console and looked at the log when this happens? There might be a clue there.