Why is the shortcut not running?

Can anybody tell me why this very simple shortcut isn’t running when I open the app “just press record”? I have other automations that runs without problem but this one doesn’t and I can’t figure out why! Any ideas?

Is “Just Press Record” an app?

What Alert is being shown? Do you need to define that?

I created the same automation and it works fine (with the most similar app I have). Try restarting your phone and see if that works?

Otherwise to isolate the issue try:

  1. Try a different app to run the automation off (e.g. I verified it works with Voice Memos)
  2. Delete and recreate the automation entirely
  3. Try something different in your “Do” list that isn’t a notification (e.g. start a timer, send an email, etc.)

Yes it is. Sorry for not pointing this out.

Hi guys,
Thank you so much for your responses and your suggestions. I actually already had done what you suggested before I wrote my post. I also waited a few hours. I was thinking, maybe it needs a little bit of time. I found myself quite ridiculous! Why should it need a little bit off time before it would work? This makes no sense at all! A few hours later I tried the shortcut again and as it still didn’t work, I wrote my post.
As I now wanted to give you a response I started with double checking if the shortcut still wouldn’t work.  And now, without any changes, it worked. It really seems like it needed some time. And I cannot understand that at all! I think I have experienced this before but didn’t really believe it because it seems so ridiculous.
So my question do you now is: what on earth is going on?
Best regards