1Password Extension

Anyone else having issues with the 1Password Chrome extension not working? When I attempt to login (press the extension icon with my cursor) nothing happens. Frustrating.

There’s the old extension and the new one. Make sure you’re using the right one: ‘1Password X’

If it doesn’t work try turning it off, quitting Chrome, relaunching, and reinstating the extension. (And failing that try deleting the extension and re-downloading the correct one again.)

Thanks. I had no idea they updated it. Would’ve been nice to get a message about that!

Well, this is apparently more confusing than I thought, so I think I was mistaken when I said the older extension was deprecated.

The 1Password X extension is apparently designed to work directly with your online 1P account, and doesn’t require the Mac app (which syncs on its own to the cloud), but the older browser extension is still shown as available for download - for those people who aren’t using a 1P subscription, I’m guessing.

Sorry about my apparently wrong statement. Anyway, I migrated to the newer extension a while back and it works fine.

Both extensions are linked to at the 1P website here.

I think I can help a little bit to clear up confusion…

1Password X is meant to work with a 1Password account and on computers which do not have a 1Password app. 1Password X is intended to “replace” the app, in that it will work entirely in the browser.

Why would you want this?

Two very common use-cases:

  1. you are using Linux
  2. you are using a Chrome Book

If you are using a Mac, you most likely want the 1Password app installed, and then you want to install the extension from https://1password.com/downloads/mac/#browsers except for Safari, because…well, long story short, Apple pretty much now requires Safari extensions to be part of an app from the Mac App Store (even more-so in Catalina than Mojave).

If you’d like to learn more about 1Password X:

HTH.

2 Likes

I have in the past had to reinstall the extension (for Safari) after updating 1Password in order to restore functionality. The extension (the ‘standard’ extension) is really now only a trigger for the new 1Password mini, and it seems that some updates have somehow broken the trigger. The reinstall fixed it no issues for me. This was Safari, though — so I can’t be sure Chrome would have the same issue/solution.

Just had the same Safari problem after upgrading. Was going to try this fix.

I’m experiencing those issues at the moment, browser integration seems broken.

I have seen this on a few Macs running High Sierra.

The “fix” seems to be to click on 1Password in the menu bar and choose “Quit 1Password Completely” and then quit Safari. Then re-launch 1Password and Safari, and it works.

Not sure why, but try that?

FWIW the 1Password X worked just fine on Chrome once I installed it. I am currently testing out Safari for a couple weeks to see if it can replace Chrome. It’ll be interesting to see if I run into any issues with 1Password on a different browser.