1password not quite what I hoped

After many years of using Dashlane and basically finding it ok, I finally dove into 1Password, expecting a vastly improved experience because of all the enthusiasm among the MPU crowd. But I’m finding a few pain points that could just be user error or maybe the apps are just different. The most obvious one right now on the Mac is with 1password 7 using Firefox. Whenever I get to a login page where I have an existing password, I see the 1pw logo, with a lock on it. When I click on the logo, I get a message saying to type cmd+. (Period). I do that, the app launches and takes me to my list of possible passwords for that location or it lists the single one. I click on autofill, and sometimes it fills everything in, others it leaves the form empty, so I have to type in the login and pw anyway. When I type the keyboard shortcut cmd-\ (backslash) it’s one or two fewer steps, but I still have to hit launch or submit or whatever is on the website (ENTER never works). I’ve tried this with multiple sites. With Dashlane, once I unlocked the master password, the form filled, the login was automatically pressed, and there I was signed in and ready to go. I’m finding similar frustrations with autofill for credit cards, addresses, etc - it just feels clunkier. The problem is widespread enough that I’m guessing it’s something user-related. I checked preferences, and nothing there seemed to be governing this behavior. But if anyone has any suggestions, I’d be grateful. At the very least, I’d love to know what a typical seamless step-by-step user experience is like with 1pw. Thanks!
Here are my specs: 1pw: 7.3.2; Mojave: 10.14.6; Firefox: 60.4.0esr

To my knowledge Dashlane only works online, 1Password has a local database that is synchronized trough their own server, iCloud. Better yet the 1Password database can be kept entirely offline and use local sync or non at all.

Using 1password and Safari, I’m able to login to sites by hitting cmd + \ and then Enter (although you make a good point that the last step probably shouldn’t be necessary). Chrome was the same experience. So maybe it’s just the Firefox integration? I can’t imagine that, though…

1 Like

cmd + \ works in firefox for me too for populating fields.

I’ve got the same range of issues, especially with FF and Brave browsers. Same on IOS - absolutely seamless 99% of the time with Safari but somewhat hit and miss with FF.

1 Like

It sounds like you’re using the 1Password X extension in Firefox instead of the 1Password extension. The X version is designed for machines that you can’t install 1Password on, so it doesn’t use the local 1Password.


FYI not being able to auto-submit is for security reasons.


I think Rosemary has it. That’s why you aren’t getting the “native” experience.

This page will show you the extensions for supported browsers:

You can get the Firefox one here https://1password.com/browsers/firefox/


I actually think Dashlane also works offline, or at least I never recall that being a problem.

Enthusiasm is not necessarily based on experience.

What? Are you saying that 1password’s aggressive marketing strategy has an impact on this?

That and people wanting to feel membership in the or a group. Not necessarily a bad thing but another factor. … or reflective of product quality.

Correct - Dashlane works offline just fine. Needs an internet connection to sync across devices, of course.

I use Firefox as well. If changing the extension doesn’t work for you, try to copy and paste from 1Password rather than typing them out. That has been my workaround.

If you’re having issues instead of implementing a workaround that requires so much work I recommend contacting 1Password support. They’re very nice and have a vested interest in making sure it’s all working!


Hi Rosemary
You know, I would have never worked that out reading the AgileBits web page. Even going back this afternoon knowing about the X version it reads as if the X version is the superior version to opt for.
Oh and yes, I had the X version installed in FF. But now I have deleted that version and replaced with the companion app … I kinda like the X version better (But I’ll give it a week and see how it goes)
Thanks for the tip. Cheers, Russell.