1password Safari extension not working

I searched here on and on the wider internet and cannot find a solution. My 1password extension in Safari is not working. There was one suggestion for pasting code into a terminal window and that didn’t work. If you have any ideas, I would appreciate them.

In Settings for Safari, you have to grant permission to the 1Password extension, like so:

This is in the Mac app. It works great on my iOS devices

Remove all your extensions, clear your cache, and quit Safari. Then restart Safari, reinstall only the 1Password extension and test it.

(When I have no clue what the problem is, I like starting over as close to default as possible). Good luck.

1 Like

The 1password safari extension wasn’t working for me on my mac, and when I googled, I fixed it by following this advice from the 1password forums:

  • am sorry for the trouble. Usually, when 1Password does not connect with Safari, we can try these quick steps and it should put things back on track most of the time.
  • Right-click on the 1Password mini icon at the far right corner of the menu bar > select “Quit 1Password Completely” > Quit all browsers > Restart your computer > Try 1Password again.

I didn’t expect it to work …. But it did.

1 Like

I admit I uninstalled the 1Password for Safari extension and just use the 1Password extension itself in Safari.

Bit confused why there are 2 but the “general” one works consistently.

1 Like

You mean the one the pops open in the password window? Yes, that seems to still work. I tried to uninstall the extension but it said that I needed to uninstall the entire program . .weird.

I think I just deleted the 1password for safari program (?) or maybe it was an extension, not safari nor 1password itself.

In any event, at the least disable the 1password for safari extension in the check box in Safari > Preferences > Extension

I checked, yes you also have to uninstall the 1password for safari application.

thanks for your help!

When the 1Password app and its extensions are updated, I find that it no longer works in Safari until I log out and then log back in. Rebooting, of course, also works, but that’s overkill, just logging out and logging back in fixes it. Give that a try.

1 Like

I use 1Password more on my iPad Pro and I find the extension rarely works. It will bring up a very short list of logins, and none of them are relevant to the site I am on.

I end up keeping 1P in split view hidden off to the right side of the screen.

1 Like