2012 Mac mini network connection very slow

I have a 2012 Mac mini and am getting awful network speeds, https://cl.ly/3843b4 I have ATT Uverse with Eero for wi-fi. The Uverse & Eero setup is kinda complicated, but has worked well up until the last week when I don’t recall anything changing.

I have the Ethernet cable plugged into a two-year old TRENDnet 8-port Unmanaged Switch (TEG-S80G). I’ve tried wifi on the mac mini and the connection is just as bad as the screenshot above. I’ve also tried plugging the cable into the router from UVerse.

iOS devices and my MacBook Pro 13 in Retina connect fine via Eero wifi. Eero says I am getting 60Mbps down and I’m paying for 50Mbps…

My Mac mini is rather useless to me if I can’t connect to it from the network.

Any thoughts?

I assume is the Mini? What is your router’s address?

The main eero is and the Uverse router is

You can’t change the Eero from using (I asked awhile ago.)

Can you change the U-Verse to use instead?

The way I have it set up is the Uverse gateway is connected to the Internet and the Eero is connected to the Uverse gateway in the DMZ for the Uverse. It has worked this way just great for the last year and the odd thing is my Wifi clients are getting fast speeds.

Well, I removed Sophos and now things seem to be okay. Getting the speeds I am accustomed to. Don’t know if it’s a coincidence or not, but I’ll take it!

What do you mean by this? (I’m asking because I’m using an Eero based network and don’t have any addresses in (by design))

Well, if that’s possible, I’d love to know how you achieved it. The eero app does not seem to give that control over the designated IP range.

Network Settings->Advanced Settings-> DHCP & NAT

You can choose the RFC1918 network prefix there along with the subnet address and netmask.

1 Like

Well shuck my corn… I wonder when they added that?

Thanks for the info. I’m glad to know that.


It’s such a rare treat to be the bearer of happy news :laughing:

1 Like