2013 21” iMac screen randomly turns on while asleep

mac

#1

Sometimes at night I will lay on my couch which is in the same room my iMac is located in. Even though it’s asleep it will randomly turn the screen on and then it will go right back off. The whole incident lasts maybe all of 10 seconds. I’ve been laying here tonight and it’s probably happened about half a dozen times in the 2 hours I’ve been in the room without ever going near it.

I’ve tried doing some searching and this appears to have been a problem that has cropped up but I have trouble locating anything about it happening to a machine from this decade. I couldn’t really find a definitive answer on what it could be and a fix.

Does anyone know why this happens and how I can stop it?


#2

Did you recently add a new device to the same network your iMac is on?

It’s possible it’s receiving a “Wake on LAN” command from something else, and that’s what’s causing it to wake up. If in System Preferences > Energy Saver > “Wake for Wi-Fi network access” is enabled, then try disabling that and seeing if it resolves the issue. If it does, then something on your network is sending out a wake command. The questions that remain are “what?” and “why?”!


#3

It’s entirely possible I did with all the different smart home stuff. Its been going on for months (may even been this whole year) so its hard to pinpoint exactly what it is that would be pinging the network.


#4

I’d suggest disabling wake for wifi network access and seeing what happens. If that resolves the issue then at least you know the “why” :wink:

The other option it might be, is a peripheral. If in System Preferences > Bluetooth > Advanced, “Allow bluetooth devices to wake this computer” is enabled we have another possibility. Now, I don’t know about you but I like not having to plug in a keyboard and/or mouse to wake up my machine - so instead of disabling this option, you could instead try turning off your keyboard and mouse and see if that fixes it!

(Also, check your desk/area for other devices which might be paired to the machine and turned on. I’ve resolved many “my computer is possessed!” issues by simply removing a bluetooth mouse or keyboard from the backpack it was in…)


#5

Thanks for the suggestions. I’ll try them in the morning when I’m back on it. If I’m being honest I always wondered if it was Apple Watch pinging it because I didn’t start noticing it until after I added the ability to unlock it with my watch. But that could be a coincidence.


#6

So I never actually got around to messing with the settings but this issue seems to have stopped since upgrading to Mojave. I also had an issue where a sleep/wake error would cause the computer to turn off and I haven’t received that since updating either.


#7

My watch and bluetooth headphones do something odd. It seems to be when I turn on my headphones sometimes I get a tap that my MBP has unlocked with my watch, thought I wasn’t using the laptop.


#8

Just doing a follow up to this issue. Ultimately I never ended up trying @RosemaryOrchard suggestion (sorry) but after updating to Mojave’s the issue no longer happens.