24-Hour Clock Turned On and Can't Be Turned Off (AppleICUForce24HourTime)

I recently tried to turn off 24-hour time on my Mac, and saw this:

With that line greyed out, I was unable to disable the 24-hour clock.

It took some searching, but I eventually discovered the key:

defaults delete "Apple Global Domain" AppleICUForce24HourTime

Entering that line in Terminal, and then restarting, allowed me to disable 24-hour time.

I have no idea where this ‘force 24 hour time’ option came from, and never chose it, but at least now I know how to fix it.


defaults read "Apple Global Domain" AppleICUForce24HourTime

equals 1 then the option is on. I assume setting it to zero (0) would also disable it, but deleting it worked, so I went with that.

Strangely enough, this happened on both of my Macs, a MacBook Air and a Mac mini. They are both running the latest version of Monterey (macOS version 12.4 (21F79)).

1 Like

What timezone/language/region have you set on your computer?

Mine is BST/UK English/UK and the 24 hour clock option is availabale as normal

Also 24hr clock is pretty much standard in Europe. In US and Asia I mostly worked with am/pm clocks, which frankly I can’t get used to…

I’m set to USA/English/US-Eastern TZ… I think 24 hour makes more sense, but I couldn’t get used to it.

I don’t assume many people will see what I saw, it’s an obscure bug, I assume. Posted for the odd one who may find it while searching.

Have you deleted language files using CleanMyMac X?

Many OS versions ago I once deleted everything but US English and I was not able to switch between 24hr and am/pm clocks anymore. Since then I have refrained from deleting the language files, but still don’t know if it was the actual reason…

Nope. Good thought though, I would tend to leave stuff like that along in the days of signatures, verifications, etc.

Last thing I can think of is another App like iStat Menus, Bartender or other systems/menubar utility overriding a global setting (for which you then must have given permission while installing)

Funny what Google finds sometimes, but apparently it is used in deployment scripts of machines:


1 Like