4TB My Book hard disk goes to sleep after just 60 seconds

My 4TB My Book hard disk goes to sleep 60 seconds after being accessed. WD Drive Utilities is set with the sleep timer OFF.

In the MacOS, I’ve tried unchecking “put hard disk to sleep when possible” and I’ve also used the Terminal to try setting the disk sleep setting to 0 minutes and 10 minutes.

None of this has made any difference. It still goes to sleep in 60 seconds. Of course, this causes frequent delays when everything jams up for three or four seconds every time I access the disk.

Any ideas what’s wrong?


M1 MacBook Air
Running Ventura OS
The disc is connected to a Twelve South Stay-Go hub, which connects to the USB C Mac socket. It’s formatted as Mac OS Extended (Journaled), with 2.49 TB available (although iStat Menus reports 0 KB free)

Is your Stay-Go Hub connected to power? I had a problem with drives dismounting when I connected them to my M1 MBA through an unpowered dock. Have you tried connecting the drive directly to your Mac?

Yes, the Stay-Go Hub is connected to power. HOWEVER, when I switched from the Stay-Go hub to a USB 3.1 socket in my fancy EIZO display, the disk stayed on. It’s been running for 30+ minutes now.

Then, I changed “Put hard disks to sleep when possible” to “Always,” and pmset -g showed disksleep had been changed to 10. I’ll watch to see if that’s working now.

I’ve had other problems with the Stay-Go Hub, such as the SD card reader working intermittently. They sent me a new one while it was still under warranty, and the SD card reading improved greatly. But other devices, like my Wacom tablet and Stream Deck, still occasionally fail, requiring a reset of the hub by disconnecting all connections to it for a few minutes. It’s a good solution for travel, but I wouldn’t recommend it for daily studio work.

Thanks for your help,