644: Some Cool Mac Utilities

1 Like

I’ve already purchased it so it was easy for me to find it.

Here’s the link:


Nice looking app and pretty cheap TBH

I listened to the pod but couldn’t figure out the use case of this app? Can’t we just use “Watch Later” feature on YouTube for track videos to watch? For cross platform websites, I could use Pocket, Instapaper, Matter and they have their extensions across all across and iOS sharesheet. What is different in this app?

1 Like

Thanks! The pretty UI and the low one time price is enticing me, even though I might not need it since I have Reeder and Pocket.

David should look into AirTags for his air pods…

1 Like

I just HAD to get iStat: I couldn’t resist. I have a maxed out intel MacBook Pro and using four times what I ever have going at once, including two browsers playing vids etc. I still only made 16GB. Confirms really what others say, I probably only really ever need a Mac Book Air with 16GB of ‘whatever they call RAM now’.


I’ll throw in my forum link for the heck of it…

David, curious if you had the option to do a frame for that extra window you don’t want in the studio, and use shutters to keep the light out. Either way, it should be easy for the future homeowner to add a window if they want one. Looking forward to seeing some photos!

David mentioned the OmniFocus Search Workflow for Alfred. I had been using this incredibly helpful workflow, but it stopped working after a macOS update on both of my Macs. I’m up to date with the workflow (2.1.3), Alfred (4.6.6), and macOS.

It starts out okay: I type one of its keywords, such as “.s” and then a space. At that point, it looks like it’s going to work. The icon and initial feedback are as expected. But as soon as I type any character after space, it changes to a Google search in Alfred. Reinstalling the workflow didn’t help.

For those of you who use it, is it still working for you?


I do not use this particular workflow, but a recent macOS update removed version 2 of Python, which many Alfred workflows required.

You might check out the Alfred forums, if you have not already, as there are threads related to this issue, as well as efforts to re-enable any such workflows.

In the list of updated workflows there is an entry for an updated version of the Search OmniFocus Workflow. Is this the one you are using?


I saw the same problem as @PatrickHoulihan - the fix noted by @MevetS took care of it perfectly.

1 Like

Thank you!!! That worked perfectly.


Thanks. I had this problem with a couple of workflows and couldn’t fix it, this should help except I’ve already moved to Raycast!

For some odd reason this episode wouldn’t download to my iPhone 13 (Downcast app). Haven’t tried another podcast app, but everything else works fine.