A catch in the music

Okay, maybe an M1 MacBook Air does not always run rings around Intel. Playing music to a new HomePod Mini via Airplay2 and the Mac’s Music app, which is a Catalyst app, has a short but distinct pause when I load an Alfred snippet or trigger an Alfred universal action. I don’t remember that happening on an Intel Mac. Maybe I need to restart the M1 Mac? Or Alfred needs an update?

Good advice. Restarting the Music app seems to have fixed the glitch.

I am very happy to blame the problem on Catalyst! Apple’s move to Catalyst for some of its homegrown apps has not been an improvement. I cordially dislike them, one and all.

1 Like

I’ve given up running Music on my Mac (2018 mini). I run it from my iPad (2018 Pro) and Airplay to an old Airport Express connected to a Denon receiver.

Annoying for sure, but a much smother experience. Still not perfect though.

That perhaps would be a better way to play music at home. No iPad at the moment though, and I prefer the Mac Music app (weak as it is) to the one on my iPhone. Instead of Airplay, I can also plug in an audio cable to my Mac and play through my stereo to two rooms. Oddly enough, a single centrally-located HomePod mini provides better coverage in my (admittedly small) house!

Yeah, when the wife wants the iPad I switch to the iPhone and while it works, it is non-optimal for sure.

I’m debating keeping the my Mini when I (eventually) get a Si Mac and using it just for music, with a direct connection to the stereo system. The hope is that Music is in better shape by then, and that if the only thing running is Music, and something like Screens to access it, Music will be more stable.

We’ll see.

1 Like