A PC guy requires help with Daughters beloved imac

Whilst trying to update from Catalina to Big Sur my daughters “Late 2014 Imac 27” 5K with 16GB ram and a3.2GB Fusion Drive , M290x GPU. went from ok speed to very very very slow to the point that it just kept on turning off. We bought an external TB2 Lacie d2 Hdd with SSD module and was able to install OS Catalina to it. Via help from Youtube bloggers. When it boots from external drive all is good except we are unable to access data that is on the internal Fusion drive. We can boot to the OS Catalina via the Fusion drive but it is very very very slow. We tried to copy file from Fusion drive to an external HDD but it says that it will take 9 days and then crashes. Question what setting could we use to access the Fusion drive once we have booted from Lacie d2 Hdd with SSD module.
Thank you

It is almost certainly a “simple permissions issue”. (Yeah, but simple for who?)

I always over architect, because I have been burned too many times by my own stupidity and impatience.

I suggest you backup and clean house in the process. There are several ways to do this. It depends on a sliding scale between easy and time consuming to difficult and quick.

The easy, but time consuming way:

  • It sounds like you have some way of booting to the internal/fusion drive and getting access to the “old” files. Then do that, and attach any USB 3 storage device you have that is large enough and copy the user’s home directory to the external hard drive. If you only have one external USB 3 hard drive, partition it to get enough to do this backup.
  • detach any and all external drives.
  • use recovery mode (CMD + R) and do a completely fresh install of the OS, wiping the internal/fusion drive clean, and go through the process of creating the default user account.
  • then create a second administrator account, DO NOT LOSE THIS PASSWORD. This is your emergency access.
  • reboot to recovery mode and turn on the security setting that allows you to boot from an external drive.
  • go to the app store and repurchase/redownload/rebuy (its free) big sur.
  • do a fresh install of big sir BUT pick the external drive.
  • reboot at set the startup drive to be the external drive.

At this point, this is as fast as that computer is going to be.

I would then make the internal fusion drive partitioned so the os/boot is as small as possible + 20 GB and use the rest as a Time Machine drive.

Just ask if you want the “give yourself root permissions and just move the data, then delete it” steps.

Thank you for a quick reply. The steps that you have listed is what I plan to do. But the problem is that Using an external HDD via USB give me the 9 day message and after a while system crashes. I was hoping that I boot from external SSD and some how unlock the internal Fusion drive. My daughter has over 40,000 photos which need to be copied over to a backup.

I’m so sorry that you’re dealing with this problem, especially with precious data.

Given your description (slow and repeatedly crashing), I fear that the internal Fusion drive is failing. The very slow behavior you saw could be the result of a completely full drive (I’ve seen it before), but you also said that it “kept on turning off”. That wasn’t “turning off”, that was crashing. I’ve never seen a permissions error so bad that it takes down the entire system — but it certainly is possible. However, given that this iMac is at least 7 years old and has a Fusion drive (not the most stable of hardware), it seems much more likely that the drive is failing.

If the drive is failing, no software can fix it. If you can’t keep it mounted long enough to copy from it, then you probably won’t be able to get data off it successfully. But a professional might be able to.

On the other hand, if this behavior is because the drive is totally full, then you might be able to get it back to operational by deleting data. This assumes that you can keep it up long enough to delete things.

Boot the Mac from the external drive. Open Disk Utility (in Applications > Utilities) — making sure you are opening the copy of Disk Utility that is on the external drive!

On the left pane you should see all of the disks that the Mac can see. If the Fusion drive is listed there, you should be able to tell how full it is. If it’s almost completely full (less than 10% free space), report back here and I can give you some things to try.

If the Fusion drive isn’t listed in Disk Utility, then it isn’t mounted and this is another indication that the drive is failing.

Repeated crashes (shut downs) are likely to cause more damage! If you are seeing regular crashes and want to preserve data, you need to stop using the Mac and take it to a professional that can try to recover the data for you. Trying to fix it yourself may make it impossible for a professional to succeed at recovering the photographs.


I believe you don’t have a “simple permissions issue” here but a failing HD.

The Fusion Drive setup requires a Traditional HD paired with an SSD. It seemed like a great idea at first, but over time the main drawback is always the spinning HD. Since this is a 2014 model I am surprised the drive lasted this long. Most Fusion setups that I have repaired in the past only make it 4-5 years before needing to be replaced.

Your daughter’s photo library lives on the spinning HD. The details you have provided about a 9 day message than the system crashes confirm my opinion. I would suggest looking into a Data Recovery service instead of the frustration of trying to copy bits and pieces of data before the next crash.

1 Like

Thanks for the advice, last time i look the drive had at least 500gb space, but I will check tomorrow.
I will update once I followed your directions.

Thanks for you advice, will follow the previous answer and if no luck then I guess that I will need to investigate professional help.
Thank you.

+1 for drive failure

Apart from trying to get data off one file at a time, maybe also try phoning Apple support to see if they have any ideas?

1 Like

Hi please see attached jpg’s.
20210805_112223|690x322, 50%
As you can see Fusion Drive folders are not accessible.
I have been able to put OS Catalina and then OS Big Sur on to external drive.
I also have a 4tb WD Red Pro (new) for the data Transfer.
Thanks for your help.

Have you tried booting the fusion drive in safe mode? Might be a way to copy the data off.

1 Like

What I see is that you don’t have Permission to access those folders. You could try to change those permissions by selecting the folder and clicking Command+I and attempt to gain access. No promises this will work.

I still believe this is a hardware issue. Failing HD in particular.

Let me be the guy (jerk, idiot, etc) to ask… are your daughters photos worth spending $2,000+ to recover? If the computer shuts down repeatedly while attempting to move files, this is your reality. I wish you all the best in trying to save them. And this is why having at least one backup is so important.

1 Like

OK, the photos show that there’s plenty of free space on the 3.2 TB internal drive. So, unfortunately, that’s not the problem of the slowness and crashes. Bummer.

Was the photo taken when you were booted from the internal drive and logged into your daughter’s account? If so, then there definitely is a permissions problem (which could be caused by data loss/damage because of repeated crashes of a dying drive).

But if the photo was taken when you were booted from an external drive, then I’m pretty sure the folders are marked inaccessible because it’s a security feature. You legitimately don’t have access to those files.
(Why? Because you aren’t logged into her account.) However, I could be totally wrong about this, as I haven’t tried this under Catalina. Apple keeps changing the rules in favor of tighter security, and I’m just not familiar with it.

But that’s irrelevant, really. The computer is extremely slow and shuts down repeatedly with no warning. That’s your immediate problem.

I would try booting into Safe mode, just in case the “shutting down with no warning” is due to some software problem that can be overridden. Just a note: this will be a slow boot process and the computer might run slow after boot. But if it does boot and it doesn’t crash (shut down w/no warning), then try copying a single file to an external drive. If that works, try a small group of files.

If that works, then it’s looking more possible that you can copy the data off the drive. I will say that macOS can be terrible about moving large quantities of files to other drives using the Finder. By terrible I mean that the copy will fail and you won’t know what has transferred and what hasn’t. And by “fail” I mean that the copy itself will stop with an error message – not that the entire computer will crash as you described above. Also, macOS is terrible at estimating how long a copy will take. Thus, the “9 days” is somewhat irrelevant.

I’m hoping that the crash was due to trying to move a damaged file. If you were trying to copy (move) a huge amount of data when you got the “9 days” warning and subsequent crash, it’s possible that the computer came across a damaged file and that caused the crash. Doing some tests with a few single files, and then slightly larger groups of files, will help sort this out.

When I have to move very large quantities of files, I use some sort of utility application to manage it (or I do it slowly by hand). These utitlies usually provide a more robust copy/move process, and they keep track of what has been moved or do it in a more logical way.

So, it may be possible to move the files in small batches, or even install a utility to make a backup of this failing drive.

In short, try Safe Mode to see if you can get a stable system. If so, then there’s hope you can use a utilty program to make some sort of backup.

But again I warn: if the Mac is crashing during these tests, then it is not likely to work. Every crash means more damage. In this case, if you really want to try to save the data, it’s time to call in the expensive professionals.


My suggestion above assumed that you were unwilling to pay for (expensive) specialty recovery, and that you just wanted to save what you could.

Installing a fresh copy of the OS on an external SSD would have taken 1-2 hours. Most of that just doing its thing while you fold laundry.

That was 4-5 days ago. If you would have used sudo to change the permissions on the drive, and then used a script to copy every jpeg in the photos folder, with multiple attempts, you would, by now, have every photo that is recoverable short of sending the drive to be physically recovered. :man_shrugging:

Hi all for some reason currently whilst OS on external drive, we are able to move data over to backup drive. Slow but it works.
Need to find out how to access Fusion drive as a normal data drive once all data has been moved.
Thank you all for you advice.


That’s great — I’m glad you found a way to get the data onto a backup drive.

If you’re lucky, the Fusion Drive’s problems are solely software. If so, then reformatting the Fusion Drive and reinstalling macOS onto it should get you back to a working Mac. Once you confirm it’s working well (i.e., not slow/crashing), then you can return the data to it.

And set up Time Machine for backup so you don’t have this problem in the future!

1 Like

I ran across this recovery software today, and thought I’d add it here in case someone needs it in the future. There are versions for Mac, Windows, and Linux, and each can recover data from any of these OSes (I.e. recover a Windows external drive attached to you Mac).


Also, helpful information on data recovery, and why it is more difficult or impossible on SSDs and SMR HDDs.