Adding a row to a Numbers table via a Shortcut

I have a Numbers table that I use to track my blood pressure. I’m trying to automate it via a shortcut on my iPad so that it prompts me for the data and then inserts a row to the end of the table in the spreadsheet. Despite several hours of tinkering and trying different approaches I have not yet been successful.

I have attached a screenshot with the current command I have entered. What is happening is it is creating a new spreadsheet with each execution and not recognizing the sheet or table references. Thanks in advance for any ideas or suggestions.

Do you have a “Get File” for the spreadsheet you are trying to update? I think that’s why you’re seeing that behavior.

1 Like

As @95omega noted, you need to Get File first, something like this:

1 Like

Hello, I realize this is almost a year later. It looks like the ‘get file’ function is no longer available ( I can’t find it). Do we use the ‘get file from folder’ function? if so I can’t get it to work. Thanks in advance (Ithis is my first time on Mac power user)

@b123 Hello and welcome :wave:

Things changed a bit when Shortcuts managed to escape the Sandbox as far as files and folders are concerned and can now save outside the Shortcuts folder.

You are right in the fact that it is now the Get File from Folder action. This is a sample of how mine works now:

In the first box (from) select the top level directory that you want to use. In the path box enter the sub-folder(s) and finish with the file name and extension.

Then add a step to actually open the file.

I had an issue where the Shortcut was running faster than the file was opening and ready to accept data, hence the 6 second delay. This was a bit of overkill in duration but meant it always worked. I haven’t tried running it without the delay for a few versions of i*OS so the delay may not even be necessary now.

Hope this helps.