Airdrop Issue - not sending to Macs from I-devices

I am having trouble sending things by AirDrop from my iPad to my desktop Mac and my Macbook. I can’t AirDrop from my iPhone to my Macs either.

Both devices show up in the AirDrop window in the sidebar. When I click on the Mac or Macbook, however, I just get a dialog “Waiting”.

The Macs are running Ventura 13.2.1. The iPad is running 16.4.1; the iPhone is running 16.4.1. Although the problem arose on 16.3 (at least).

I have tried the suggestions mentioned:

Fix AirDrop Not Working on Mac Ventura with iOS 16 in 2023
](Fix AirDrop Not Working on Mac Ventura with iOS 16.4.1 in 2023)

Air Drop stopped working after I updated … - Apple Community favicon.ico

AirDrop stops working on Mac - Apple Community favicon.ico

How to Fix The Mac AirDrop Not Working Issue favicon.png
](How to Fix The Mac AirDrop Not Working Issue)

6 ways to fix AirDrop not working on your iPhone, iPad, or Mac
](AirDrop Not Working: 6 Fixes on iPhone, iPad, and Mac)

Except reinstalling the OS on the Mac.

This is particularly annoying as I often sign documents with the Pen on my iPad and then transfer them over to my Mac(S) and have Hazel file them.

Any ideas would be much appreciated?

1 Like

Are you using a VPN? When I use a VPN on my Mac, AirDrop never works properly.

I’m having a similar issue with Ventura but unlike you, I haven’t actually search for a reason or report it as a bug. With Monterey it was a good experience, now I sometimes get it to work and end up sending things through messages.

Can you AirDrop from your phone to someone else’s phone or Mac?

Have you tried AirDropping from your Mac to your iPhone?

Doing these is not going to solve the problem, but success or failure might provide useful data points to have in hand when you setup a support call with Apple and try to recreate the problem(s).


It doesn’t go from my Mac to my iphone either.

Have you tried changing the Airdrop setting to Everyone?