Airdrop issues - separate AppleIDs and Photo libraries

So, my wife just got herself the new iPad Air for her business. This is logged in to a fresh AppleID. She also uses her iPhone for taking photos, logged into her personal AppleID.

The goal is to send images (work photos) from the iPhone over to the iPad, then DELETE the “work photos” off her phone.

Now - how do we transfer images from her iPhone to the iPad? We are trying to use Airdrop, as this supposedly sends the full-quality images over. However, the iPad Air does not show up as an Airdrop target?

We did add this new AppleID to our “Family” too, but need to keep the image libraries separate.

Any ideas?


Have you confirmed that airdrop is enabled (Settings > General > Airdrop) on both devices? And if it is on, which option is selected (contacts only or everyone)? If it is set to “Contacts Only”, then make sure that the other device is listed in the Contacts of each device.

There have been occasions when I have still not had success and temporarily switched the setting to “Everyone” and that allowed it to work.


Thanks Waylan, yes. As she’s doing a multi-year migration now, that “Everyone for 10 minutes” option isn’t great.

However, here’s what I did:
From her “old” AppleID and ContactCard - removed her “Work” email entry.
On her “new” AppleID and ContactCard - removed her phone number.

Now, when I try to Airdrop, I get both her entries. I was under the impression that the actual AppleIDs would present as two different entries, despite having common email and phone info. Seems this is not the case. (FYI - the “primary eMail” used to log in on the two accounts were NOT the same.)

So, for now, it seems we have a functioning work-around.

1 Like

Be aware that for this to occur you need to toggle the ‘All Photos Data’ setting before you initiate the AirDrop transfer. This can be found via the Options menu at the top of the screen after you’ve pressed the share button.

Oh dang - thanks man!

I wasn’t aware of this setting - need to check how it’s set on her devices. Hopefully, it’s a sticky setting once enabled.

So many ways to screw stuff up :slight_smile: