Airpods Pro -- Press and Hold Airpods

I received a pair of AirPods Pro for Christmas this year. They worked really well for a few weeks, but then the left “bud” would often cut in and out with the noise cancellation. I contacted Apple Support and they ended up (very quickly) sending me a replacement pair. The replacement pair sounds fine, but I’m experiencing a new, stubborn issue.

I like to set them up so pressing the right “bud” activates Siri. I do this in the AirPods settings and it works fine, but after a few hours it forgets this setting and reverts both sides back to “Noise Control”. I’ve been Google’ing the issue here and there, trying the following – none of which worked:

  • Resetting the Airpods. On the phone I say “Forget this Device” and then once removed, pressing and holding the button on the AP case until the light is amber. I then re-pair
  • Same as previous step, but leaving the case open while they re-pair
  • Same as step 1 but before re-pairing to phone, I go into iCloud on the web and remove the Airpods from my account
  • Erased my phone and watch and setup both as “new” installs

None of that has fixed the issue. I’ve tried doing an online support with Apple, but they’re so slow. It takes them 2 minutes to respond to everything and all they’re going to ask me to do is the steps I listed above again.

My last remaining hope is that 14.5 has some sort of magical “fix” in it when it comes out. Unless any of you have any ideas?

Forgot to mention – tried that too!
I thought it was going to work – had a feeling, but no dice unfortunately.

Good call though!