Alfred not finding recently used files in apps

When I want to open a recent document, I thought Alfred would provide me with a quick way. E.g. I start the Alfred “spotlight search”, type in “Word”. Then with my right arrow key I go into the next menu. The top one is then “Recent documents…”. With my right arrow key I go into that menu, and then I see only three documents that I worked on years ago. Nothing recent. Not the 10 or so Word documents that I worked on yesterday. I have added my whole documents folder to the Search Scope, but that doesn’t help. Any idea how I can make Alfred look for my recently used files the proper way?

1 Like

From the Alfred website:

Known issue: this feature is not fully compatible with Microsoft Office and some other non-Cocoa (non-native macOS) applications. In these cases, only files opened with Alfred will appear in results due to the limitation of the third party software.

Are these synched with onedrive? I’ve had to tell Alfred to look in the new folders and seems to find my excel recents ok.

Something changed yesterday, because for the last several years I could find Excel OneDrive files with Alfred. As of yesterday, I can’t.

If you’ve had a OneDrive update you might need to update your search scope, I had to add the following:
CleanShot 2022-01-26 at 14.21.57@2x

also: does Alfred have full disk access permissions?

That worked, thank you. I am still curious why it was suddenly broken. Change is coming…

Thanks, that would explain it!

New version of OneDrive as discussed in the macOS 12.3 changes affecting DropBox and OneDrive - Software - MPU Talk (macpowerusers.com) thread

Yes, but thank you for the tip!

No they are in iCloud

Has Alfred been weird all of a sudden for anyone else? Not just what @Skoobanul posted about, but lately my searches are all off. It’s not showing files I update regularly, bookmarks are not getting shown due to files with the partial same name showing instead (ex: Amazon bookmark not coming up, but files with “Amazon” in their name showing, even though I didn’t press space to do a file search), and then today, Alfred just quit. No messages, it just wasn’t running seconds after using it.

I guess the patch this week was buggy?

Try “Rebuild macOS Metadata”

1 Like