Anybody having issues with Fantastical today?

Fantastical latest version isn’t working for me today. Just shows an empty screen (only title bar and 3 coloured window close etc icons). Flexibits sign in for contacting support at Flexibits also isn’t working (coincidence, or not?).

Anybody else? Any tips? I’ve tried reinstalling on my mac - didn’t help. Appears fine on iOS.

Using BusyCal in the meantime but Fantastical really is the better calendar app (when it’s working at least).

Update #1: the site had logged me in once I went back to the form, despite the login page not responding.

Update #2: The help form now won’t submit either. Tried to tweet at @Flexibits for help but they don’t allow DMs.

All good here for me in the UK. Both macOS and iOS are working as expected.

No issues with the app, but I’m already signed in. The login page on the web is hanging for me after submitting, but I opened in another tab afterwards and it showed me my account.

All good here. I am signed into both and Fantastical on macOS, iOS/watchOS, and iPadOS.

Hi Vincent, Just noticed that you, too, are in NZ. Thought I’d say hello!

I had a funny glitch with Fantastical yesterday too, but I’m not sure if that was because I was restoring my Mac, or if it was a wider incident. It’s all okay now.