Anyone else experiencing a copy/cut --> Paste bug in Obsidian Mobile?

We strongly recommend you to search the forum with possible keywords before submitting a new bug report. Please also try your repro steps with third-party plugins and custom CSS disabled and see if it’s still reproducible. If it’s an issue with third-party plugins or themes, try contacting the author for help. Once you’ve done the above, delete this line.

Steps to reproduce

Select text to copy or cut then select to paste that text elsewhere in an Obsidian document.

Expected result

The text will paste.

Actual result

The text will not paste from either a cut or copy.


  • Operating system: iPad OS 14.7.1
  • Obsidian version: 1.0.4
    I’ve cross-posted this as a bug report in the Obsidian forum but I also wanted to ask here if anyone else is seeing this bug. It is present in every theme I’ve tried, including the default theme so this is not a theme issue.

Additional information

1.0.4 just tried and is working fine on my iPhone and iPad.

I did some more testing. This may not be a bug, if not, my apologies for the post. The problem seems to be isolated to a few documents, which is odd. The cut/paste feature seems to be working on most documents.

1 Like

It is inconsistent, for sure. I generally have no troubles but once in a while I notice copy/cut/paste and the various iOS edit bars aren’t working perfectly.

1 Like

I certainly don’t wish you trouble but I’m actually “glad” to hear that. I’m glad to know that it is not just me but there is a sporadic problem. I probably need to modify the bug report so as not to give the impression that there is not an issue.

1 Like

Sporadic indeed! I’ll post on your Obsidian forum thread to confirm I can reproduce it (inconsistently) too.

1 Like

@ryanjamurphy I’ve also noticed that the problem I reported earlier about email linking in Obsidian mobile has not be fixed in the latest mobile version.