Anyone Else Having Issues with Setapp

As of Thursday 9/23, I noticed that none of my Setapp Apps were working. I even tried the Setapp App and it doesn’t launch either. When I launch a Setapp App, it starts to launch and then stops. Eventually the Activity Monitor identifies the App as Not Responding. I suspect that their license servers are down.

Just thought I would check to see if anyone else was experiencing the same problem, or if it was just me. I did send a support note to Setapp as well.


1 Like

I just did a nuke and pave on my MBP and loaded 6 Setapp apps yesterday. All are woking fine. This morning I clicked on the menubar icon for Forecast Bar and got a beachball and it did not open. I tried a force quit and the name Forecast Bar did not appear. I looked in my Applications folder and it did not appear there nor in the Setapp folder within the Applications folder. Same results after a reboot. I reinstalled Forecast Bar from Setapp and it appears to be working as expected. Will post here if I run into any problems with Setapp.

I am experiencing this right now (Sept 25, 2022 ~ 9AM CST).