APFS Format on a Samsung T5 SSD

I’ve just got hold of a really rather nice 500GB Samsung T5 SSD.
This little external drive has USB 3.1, a great form-factor and is nice and fast.
It comes formatted in some FAT format and I wanted to move over to an Apple format - strangely there isn’t an option to make it APFS.
Can I format external SSDs as APFS? (I have the option with an external HD)
Does anyone know how to reveal the APFS option for an external SSD?

Same here. It wasn’t an option. I thought it would have been.


It can be done. I have done it. But I do not have access to it right now guiding you through the process.

Key is that disk utility hides some devices on default and you must change the partitioning of the device to GUID. That is necessary to have APFS available setting up a new container. Have a look at this article (instructions for Carbon Copy Cloner, but it can be used for almost every other use case):

An excerpt:

Disk Utility in High Sierra offers a very simplified view of your devices by default. Unfortunately, this hides the devices that you need to select to modify the partitioning of your backup disk. Before doing anything else in Disk Utility, choose Show All Devices from the View menu, or from the View popup button in Disk Utility’s toolbar.

(…) Click to select the disk that you would like to use for your backup. (…)

Click on the Erase button in Disk Utility’s toolbar, then configure the name, format, and partitioning scheme of your backup disk. You can set the name to whatever you like, but set the Scheme to GUID Partition Map.
Starting in macOS High Sierra, both APFS and Mac OS Extended (Journaled) are acceptable formats for a backup of macOS 10.13. Mirroring Apple’s recommendations, we recommend that you choose APFS if your destination device is a Flash storage-based device (e.g. an SSD) and will be used to back up 10.13 or higher. (…)

There is a downside to going down the APFS route: If my Samsung T5 (APFS) is connected, sometimes my iMac will not show the Apple logo when starting up or the logo will come after quite a long time. It might be an APFS issue, it might be a Samsung issue, it might be an issue because there is an APFS container with a clone backup of my iMac on it. I did not have the issue when I used Mac OS Journaled on my external SSD.

Keep in mind that you will use all Samsung proprietary stuff on the SSD (encryption stuff and so on). For me, it was a no-brainer to get rid of it.


I was able to format following your instructions. Thank you.

Can you tell me why the drive, when I have it selected and I click the info ‘i’ in the top right corner of disc utility, shows a ‘No’ where it says Solid State? Is this not important, or should it not say Yes, as it is an SSD.

just picked up a bargain t5 and couldn’t get it to format apfs - thanks for this :slight_smile:

1 Like

I have two T5’s (500 Gb and 1 TB) hanging off my entry level 2018 Mac mini. I was able to reformat the smaller one into APFS, but I couldn’t get the larger one to erase in Disk Utility. I kept getting an error message that the operation couldn’t be completed. Not sure what I’m going to do, I might try to get a warranty replacement.

It is a pain when something like that happens. The easiest way may be getting a replacement.

Something different to try would be to do something crazy:

When I changed my NAS from QNAP to Synology, I had difficulties to wipe the hard drives and to get them recognized in the Synology NAS. Neither my Mac nor the Synology NAS recognized the hard drives correctly.

I attached the hard drives to a PC and used the Windows disk management tool to wipe the disks including their file system.

It worked like a charm. If you have access to a PC, it might be worth a try to delete everything (including partitions) from the SSD including the file system.

I have 2 T5’s and just checked the one that is currently plugged in. Both the volume and the device say “Solid state no” in the info panel. Interesting…

I changed the type from APFS to APFS Encrypted and it finally worked. That’s better anyhow, as this is the container for all our family’s photo libraries.

I just got one of these drives and had a little problem getting it formatted properly.

It came formatted as exFAT with a Master Boot Record or something like that.

Here’s the important hint: the problem is with the way Disk Utility.app works now is that you don’t always see the “root” of the drive.

Make sure you go to View » Show All Devices:

Then you will see the “parent” items as well as the volumes.

Be sure that you select the “top” listing as shown with the arrow below:

Once you have that selected, go up and click “Erase” and make sure that it is set to “APFS” and “GUID Partition Map”.

Obviously this will erase everything on it, so be sure there’s nothing on it you care about.


That is true:

Bombich has a nice step-by-step tutorial online explaining that procedure.

1 Like

I figured how to format the T5 to the APFS. I did it to get rid of the Samsung software that worked poorly. However, I find the speed of my T5 is pretty slow now. Do you have the same problems?

Not at all. In fact I’ve been using mine to contain my entire $HOME and it feels almost as fast as internal storage.


No, it feels fast. No issues.

It might be a good idea to check the cable’s capabilities (it is a mess these days) and of course the port the device is connected to. Otherwise, it might be a defective device.


I’m using one as external boot drive on an iMac and found no speed issues at all.


I bought an usb c 3.1 gen 2 cable from Amazon. I also tested the usb c cable that comes with Apple to charge the MB pro 2016. Both have that problem. I someone could test out if their macbook charging cable delivers the speed when next using the SSD would be great.

Anyways thanks for letting me know this!