Apple Mail Crashing Constantly

Hi, all. I’ve been dealing for months with repeated Apple Mail crashes, always with the following error:

Crashed Thread: 13 Dispatch queue:

Exception Codes: KERN_PROTECTION_FAILURE at 0x00000002a7eb7ff0
Exception Codes: 0x0000000000000002, 0x00000002a7eb7ff0

Termination Reason: Namespace SIGNAL, Code 10 Bus error: 10
Terminating Process: exc handler [22448]

I have the same email accounts on another Mac and don’t have this issue, so I guess it’s something particular to this machine (a Mac Studio running the latest MacOS). I’ve tried all the usual steps – rebuilding mailboxes, deleting all accounts altogether, deleting Mail extensions. Nothing has solved it, and it has persisted through the last several MacOS updates.

Is my only remaining option a complete reinstall of MacOS? I haven’t found a solution that works via Google. Any thoughts welcome.

(P.S. – no, Apple has not responded to my Feedback reports… I’m not holding my breath.)

Is this all you’re getting? No stack traces?

You could try vacuuming the mail database. It ‘s a Terminal command - syntax varies slightly depending which version of MacOS you use. Google should be able to help.

For Monterey, it’s sqlite3 ~/Library/Mail/V9/MailData/Envelope\ Index vacuum;

Any plug-ins remaining?

I can’t interpret the error message’s jargon. But it seems to be something with “.contentIndex”. Does this imply search? Perhaps rebuild the Spotlight index? and/or take Mail out of Spotlight’s list of Search Results. (Wild guesses)

The crash report is quite long. I only posted the summary that describes which thread crashed. Is there something more I should be looking for in the crash report?

Thank you – I’ll check this out.

I had the same thought and tried this already. No luck.

The stack trace might give us a clue. You can post just the stack trace for thread 13, or you could use PasteBin or something similar.

Have you tried holding down Shift when you open Mail? I can’t get an Apple-sanctioned description of with this may do in Mail, but it’s a way to prevent an app from re-opening windows (restoring state), and sometimes it might dump the cache or reset some settings. I found a message thread on Apple’s forums where doing the “shift open Mail” twice in a row, then immediately rebooting, fixed some problems.

Worth a try as it’s minimally destructive.

If that doesn’t do it, I’d try reinstalling the operating system over top of the current installation. Again, this is minimally destructive and may fix it if it’s due to corruption of the OS.

1 Like

Thank you all for the great thoughts! I will give these a try.

This is part of the stack trace (I think?). It’s Thread 11 in this example, as this is the crash I copied from. I pasted the first 12 rows for brevity, but it repeats the same “performSelector…” language over and over for 512 rows.

Thread 11 Crashed:: Dispatch queue:
0 libsystem_kernel.dylib 0x1b6d72504 kdebug_is_enabled + 4
1 libsystem_kernel.dylib 0x1b6d72614 kdebug_trace + 48
2 CoreFoundation 0x1b6e611a8 CFRunLoopWakeUp + 284
3 Foundation 0x1b7d4e1e4 -[NSThread _nq:] + 508
4 Foundation 0x1b7d4ddf8 -[NSObject(NSThreadPerformAdditions) performSelector:onThread:withObject:waitUntilDone:modes:] + 956
5 Foundation 0x1b7d4d87c -[NSObject(NSThreadPerformAdditions) performSelectorOnMainThread:withObject:waitUntilDone:] + 136
6 Foundation 0x1b7d812e8 -[_NSThreadPerformInfo dealloc] + 48
7 Foundation 0x1b7d4d87c -[NSObject(NSThreadPerformAdditions) performSelectorOnMainThread:withObject:waitUntilDone:] + 136
8 Foundation 0x1b7d812e8 -[_NSThreadPerformInfo dealloc] + 48
9 Foundation 0x1b7d4d87c -[NSObject(NSThreadPerformAdditions) performSelectorOnMainThread:withObject:waitUntilDone:] + 136
10 Foundation 0x1b7d812e8 -[_NSThreadPerformInfo dealloc] + 48
11 Foundation 0x1b7d4d87c -[NSObject(NSThreadPerformAdditions) performSelectorOnMainThread:withObject:waitUntilDone:] + 136
12 Foundation 0x1b7d812e8 -[_NSThreadPerformInfo dealloc] + 48

I’m confused. In your initial post the screenshot says “Crashed thread: 13”.

The thread often changes – I assume because it’s whatever thread Mail is using for that process at the time of the crash? It’s always the same “…” regardless of which thread it is on.

1 Like

Well, I re-installed macOS, and mail is still crashing. I don’t think I can bring myself to do a full wipe of the computer. Maybe I’ll see if the Ventura upgrade fixes it in October…

Ah, I understand now. I thought we were working with the same crash report as before.

It does seem to be an indexing issue, and I don’t think reinstalling macOS would resolve that. I found this article, which details how to force a reindexing. The useful bits are further down so be sure to read the whole article.

The article refers to ~/Library/Mail/V2/MailData; your machine will undoubtedly not be using V2, just change V2 to whatever you have. On my machine I have V2, V6, and V9, but only V9 contains anything useful.

If you’re not comfortable doing this, I think your only other option is Apple Support.

Thank you – I’ll take a look.